poj2828 Buy Tickets (線段樹)

Buy Tickets
Time Limit: 4000MS   Memory Limit: 65536K
Total Submissions: 15862   Accepted: 7902

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ i ≤ N). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.


題意:插隊買車票,求最後排隊次序。

從後往前想數組中插入,輸入的兩個數a[i],v[i]分別表示插入v[i]的位置前還有a[i]個空位。

用線段樹記錄區間中的空位個數,每輸入一次找到應在的位置,賦值並更新樹。

函數名正常應該是update的,敲題的時候覺得是在查詢v[i]在數組中的位置,就寫了query......現在越看越怪異尷尬

對了。。還有個問題,爲了小小的偷懶 ,define了一堆東西,但是如果把mid define爲(l + r) >> 1就不能運行,出現錯誤。好奇怪,到現在也不知道爲什麼。。。。

#include <cstdio>
#include <iostream>
#include <algorithm>
#define ls node << 1
#define rs node << 1 | 1
#define lson l, mid, ls
#define rson mid + 1, r, rs
#define maxn 200005

using namespace std;

int n, a[maxn], v[maxn];
int sum[maxn << 2], num[maxn];

void pushup(int node)
{
    sum[node] = sum[ls] + sum[rs];
}

void build(int l, int r, int node)
{
    if(l == r) {
        sum[node] = 1;
        return;
    }
    int mid = (l + r) >> 1;
    build(lson);
    build(rson);
    pushup(node);
}

void query(int x, int y, int l, int r, int node)
{
    if(l == r) {
        sum[node] = 0;
        num[l] = y;
        return;
    }
    int mid = (l + r) >> 1;
    if(x > sum[ls])
        query(x - sum[ls], y, rson);
    if(x <= sum[ls])
        query(x, y, lson);
    pushup(node);
}

int main()
{
    while(scanf("%d",&n) != EOF) {
        for(int i = 1; i <= n; i++) {
            scanf("%d%d",&a[i],&v[i]);
            a[i]++;
        }
        build(1,n,1);
        for(int i = n; i > 0; i--) {
            query(a[i], v[i], 1, n, 1);
        }
        for(int i = 1; i < n; i++)
            printf("%d ",num[i]);
        printf("%d\n",num[n]);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章