HDU 1069 Monkey and Banana(動態規劃DP 經典)

原題

Monkey and Banana


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)


Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.


Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.


Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".


Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0


Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

題意

把給定的長方體(不限)疊加在一起,疊加的條件是,上面一個長方體的長和寬都比下面長方體的長和寬短;
求這些長方體能疊加的最高的高度.(其中(3,2,1)可以擺放成(3,1,2)、(2,1,3)等).

涉及知識及算法


動態規劃 類似於求最長上升子序列
初始化 dp[i]=box[i].h
狀態轉移方程 dp[i] = max(dp[i],dp[j] + box[i].h)

代碼

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

struct node
{
     int l,w,h;
};
//存放長方體不同的擺放方式
node box[91];
//前大後小
bool cmp(node a,node b)
{
    if(a.l>b.l)
    {
        return true;
    }
    else if(a.l==b.l&&a.w>b.w)
    {
        return true;
    }
    else
    {
        return false;
    }
}

int main()
{
    int c=1;
    //freopen("in.txt","r",stdin);
    int n;
    while(scanf("%d",&n)&&n)
    {
        int d[3];
        for(int i=0;i<n;i++)
        {
            scanf("%d%d%d",&d[0],&d[1],&d[2]);
            sort(d,d+3);
            //將長方體按不同的高度分爲三類
            box[3*i].h=d[0];box[3*i].l=d[2];box[3*i].w=d[1];
            box[3*i+1].h=d[1];box[3*i+1].l=d[2];box[3*i+1].w=d[0];
            box[3*i+2].h=d[2];box[3*i+2].l=d[1];box[3*i+2].w=d[0];
        }
        //排一下序使得前面的面積大致大於後面的
        sort(box,box+n*3,cmp);
        int dp[91];
        for(int i=0;i<n*3;i++)
        {
            dp[i]=box[i].h;
        }
        //從面積第二小的開始擺
        for(int i=n*3-2;i>=0;i--)
        {
            for(int j=i+1;j<n*3;j++)
            {
                if(box[i].l>box[j].l&&box[i].w>box[j].w&&dp[i]<dp[j]+box[i].h)
                {
                    dp[i]=dp[j]+box[i].h;
                }
            }
        }
        int sumh=-999;
        for(int i=0;i<n*3;i++)
        {
            if(sumh<dp[i])
            {
                sumh=dp[i];
            }
        }
        printf("Case %d: maximum height = %d\n",c++,sumh);
    }
    return 0;
}
代碼引自CSDN博主秦石秦草,鏈接http://blog.csdn.net/qinmusiyan/article/details/7986263,表示感謝。

發佈了25 篇原創文章 · 獲贊 9 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章