POJ 3253 Fence Repair(優先隊列構造哈夫曼樹)

原題

Fence Repair

Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank
Output
Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

題意


割木板,割木板的長度就是花的錢。比如你要8 8 5 的木板,最簡單的方式是把21的木板割成13,8,花費21,再把13割成5,8,花費13,共計34,當然也可以先割成16,5的木板,花費21,再把16割兩個8,花費16,總計37,現在就是問你花費最少的情況。

涉及知識及算法


爲了保證花費最少,那就要每割一次,使下一次被割的木板長度儘可能小,這樣就轉換爲了哈夫曼樹問題。代碼的精彩之處在於利用優先隊列特性來構造哈夫曼樹。

代碼

#include <iostream>
#include <cstdio>
#include <vector>
#include <queue>
#include <functional>
using namespace std;

int a[20005];

int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        priority_queue<int,vector<int>,greater<int> > que;
        for(int i=0;i<n;i++)
        {
            scanf("%d",a+i);
            que.push(a[i]);
        }
        long long ans=0;
        int L1,L2;
        while(que.size()>1)
        {
            L1=que.top();
            que.pop();
            L2=que.top();
            que.pop();
            ans+=L1+L2;
            que.push(L1+L2);
        }
        printf("%lld\n",ans);
    }
    return 0;
}


代碼轉自CSDN博主陳宇龍加油加油加油,鏈接http://blog.csdn.net/since_natural_ran/article/details/53290639 ,向他表示感謝。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章