2017 Multi-University Training Contest - Team 2,HDU 6045 Is Derek lying?(思維水題)

原題

Is Derek lying?


Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Problem Description

Derek and Alfia are good friends.Derek is Chinese,and Alfia is Austrian.This summer holiday,they both participate in the summer camp of Borussia Dortmund.During the summer camp,there will be fan tests at intervals.The test consists of N choice questions and each question is followed by three choices marked “A” “B” and “C”.Each question has only one correct answer and each question is worth 1 point.It means that if your answer for this question is right,you can get 1 point.The total score of a person is the sum of marks for all questions.When the test is over,the computer will tell Derek the total score of him and Alfia.Then Alfia will ask Derek the total score of her and he will tell her: “My total score is X,your total score is Y.”But Derek is naughty,sometimes he may lie to her. Here give you the answer that Derek and Alfia made,you should judge whether Derek is lying.If there exists a set of standard answer satisfy the total score that Derek said,you can consider he is not lying,otherwise he is lying.

Input

The first line consists of an integer T,represents the number of test cases.

For each test case,there will be three lines.

The first line consists of three integers N,X,Y,the meaning is mentioned above.

The second line consists of N characters,each character is “A” “B” or “C”,which represents the answer of Derek for each question.

The third line consists of N characters,the same form as the second line,which represents the answer of Alfia for each question.

Data Range:1≤N≤80000,0≤X,Y≤N,∑Ti=1N≤300000


Output

For each test case,the output will be only a line.

Please print “Lying” if you can make sure that Derek is lying,otherwise please print “Not lying”.


Sample Input

2
3 1 3
AAA
ABC
5 5 0
ABCBC
ACBCB

Sample Output

Not lying
Lying

題意


有n道題,每個題有ABC三個選項,有一個答案是正確的。每道題做對得一分,做錯不得分,給定命題:“第一個人得X分,第二個人得Y分”,然後有這兩個人關於這n道題得答案,判斷一下這個答案序列能否成立。

涉及知識及算法

考慮到只有兩種情況下這是不正確的:

1.x+y超過了給定答案能夠提供的最大分數,這是x+y的上界。注意,x+y是沒有下界的(可以答對0道)

故x+y<=n+cnt

2.x與y的差值過大。例如,答案全爲相同的,x與y的差值爲1。處理這種情況時,找到差值的上界(差值只能從不相同的答案得到),比較即可。

故abs(x-y)<=n-cnt

代碼

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

char s1[80005],s2[80005];
int main()
{
    int a,b,n,t,cnt;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&a,&b);
        scanf("%s",s1);
        scanf("%s",s2);
        cnt=0;
        for(int i=0;i<n;i++)
        {
            if(s1[i]==s2[i])
            {
                cnt++;   //相同個數
            }
        }
        if(abs(a-b)<=n-cnt&&a+b<=n+cnt)
        {
            printf("Not lying\n");
        }
        else
        {
            printf("Lying\n");
        }
    }
    return 0;
}


文章部分內容轉載自博客園博主Pic,鏈接http://www.cnblogs.com/liuzhanshan/p/7249358.html
發佈了25 篇原創文章 · 獲贊 9 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章