數字三角形

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 34666   Accepted: 20680

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

以下往上走,上面給的保存,下兩個的最大值加本身
最頂上的就是最大值
#include<stdio.h>
int tri[101][101];
int d[101][101];

int max(int a, int b){
	if(a > b)
		return a;
	else
		return b;
}

int main()
{
	int n;
	int i, j;
	scanf("%d", &n);
	for(i = 1; i <= n; i++)//輸入
		for(j = 1; j <= i; j++){
			scanf("%d", &tri[i][j]);
			d[i][j] = tri[i][j];
		}		

		for(i = n - 1; i >= 1; i--)//從倒數第2層開始找
			for(j = 1; j <= i; j++){
				d[i][j] = d[i][j] + max(d[i+1][j], d[i+1][j+1]); 				
			}

			printf("%d\n", d[1][1]);
	return 0;
}


發佈了84 篇原創文章 · 獲贊 8 · 訪問量 5萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章