文章標題

Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 19461 Accepted: 8670
Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2..N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.
Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output

3
Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.
Source

USACO 2007 Open Gold

上個周做連通圖是用縮點,這題是恰恰相反,是拆點,妙哉,把一個牛拆成兩個點,牛左,牛右,於是就有:源點→食物→牛左→牛右→飲料→匯點 每條邊的容量都是1,因爲只有一份食物和飲料,然後跑EK就可以了(模板是找的)

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
#include <vector>
using namespace std;
const int MAXNODE = 800;
const int MAXEDGE = 100010;
typedef int Type;
const Type INF = 0x3f3f3f3f;

struct Edge{
    int u, v, next;
    Type cap, flow;  //容量 流量;
    Edge() {}
    Edge(int u, int v, Type cap, Type flow, int next): u(u), v(v), cap(cap), flow(flow), next(next){}
};

struct EK{
    int n, m, s, t;
    Edge edges[MAXEDGE];
    int head[MAXNODE], pre[MAXNODE];
    bool vis[MAXNODE];
    vector<int> cut;

    void init(int n) {
        this->n = n;
        memset(head, -1, sizeof(head));
        m = 0;
    }

    void AddEdge(int u, int v, Type cap) {
        edges[m] = Edge(u, v, cap, 0, head[u]);
        head[u] = m++;
        edges[m] = Edge(v, u, 0, 0, head[v]);
        head[v] = m++;
    }

    //通過BFS構建層次圖,並在層次圖中找到增廣路
    bool BFS() {
        queue<int> Q;
        memset(vis, 0, sizeof(vis));
        vis[s] = 1;
        Q.push(s);

        while (!Q.empty()) {
            int u = Q.front(); Q.pop();

            for (int i = head[u]; ~i; i = edges[i].next) {
                Edge &e = edges[i];
                if (!vis[e.v] && e.cap > e.flow) {
                    vis[e.v] = true;
                    pre[e.v] = i;
                    if (e.v == t)
                        return true;
                    Q.push(e.v);
                }
            }
        }
        return false;
    }

    //增廣,並修改每條邊的流量
    Type Augment() {
        int u = t;
        Type flow = INF;
        while (u != s) {
            Edge &e = edges[pre[u]];
            flow = min(flow, e.cap - e.flow);
            u = e.u;
        }

        u = t;
        while (u != s) {
            edges[pre[u]].flow += flow;
            edges[pre[u] ^ 1].flow -= flow;
            u = edges[pre[u]].u;
        }
        return flow;
    }

    Type Maxflow(int s, int t) {
        this->s = s; this->t = t;
        Type flow = 0;

        while (BFS()) flow += Augment();
        return flow;
    }

    void Mincut() {
        cut.clear();
        for (int i = 0; i < m; i += 2)
            if (vis[edges[i].u] && !vis[edges[i].v] && edges[i].cap)
                cut.push_back(i);

    }
}ek;

int main()
{
    int n,f,d;
    int a,b,c;
    while(scanf("%d%d%d",&n,&f,&d)==3)
    {
        ek.init(2*n+f+d+1);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a,&b);
            for(int j=0;j<a;j++)
            {
                scanf("%d",&c);
                ek.AddEdge(c,2*i-1+d+f,1);
            }
            ek.AddEdge(2*i-1+d+f,2*i+d+f,1);
            for(int j=0;j<b;j++)
            {
                scanf("%d",&c);
                ek.AddEdge(2*i+d+f,c+f,1);
            }
        }
        for(int i=1;i<=f;i++)
        {
            ek.AddEdge(0,i,1);
        }
        for(int i=f+1;i<=f+d;i++)
        {
            ek.AddEdge(i,2*n+f+d+1,1);
        }
        int ans=ek.Maxflow(0,2*n+d+f+1);
            printf("%d\n",ans);
    }
}
發佈了102 篇原創文章 · 獲贊 7 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章