hdu 5017 Ellipsoid(模擬退火)

Ellipsoid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1140    Accepted Submission(s): 412
Special Judge


Problem Description
Given a 3-dimension ellipsoid(橢球面)

your task is to find the minimal distance between the original point (0,0,0) and points on the ellipsoid. The distance between two points (x1,y1,z1) and (x2,y2,z2) is defined as 
 

Input
There are multiple test cases. Please process till EOF.

For each testcase, one line contains 6 real number a,b,c(0 < a,b,c,< 1),d,e,f(0 ≤ d,e,f < 1), as described above. It is guaranteed that the input data forms a ellipsoid. All numbers are fit in double.
 

Output
For each test contains one line. Describes the minimal distance. Answer will be considered as correct if their absolute error is less than 10-5.
 

Sample Input
1 0.04 0.01 0 0 0
 

Sample Output
1.0000000
 

Source
 

題解:
       這題也是看了看別人的題解,學習了一下模擬退火,感覺不難,挺簡單。整體的思路就是8個方向的搜索,退火的意思就是逐漸縮小搜索範圍,從而使最後的解足夠精確。

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
using namespace std;
const double sp=0.99,eps=1e-8;
double a,b,c,d,e,f,M=1e9;
double dirx[]={-1,-1,-1,0,0,1,1,1};
double diry[]={-1,0,1,-1,1,-1,0,1};

double dis(double x,double y,double z)
{
    return sqrt(x*x+y*y+z*z);
}

double getz(double x,double y)
{
    double A=0,B=0,C=0;
    A=c;
    B=d*y+e*x;
    C=a*x*x+b*y*y+f*x*y-1;
    double delta=B*B-4*A*C;
    if(delta<0) return M;
    double z1=(sqrt(delta)-B)/(2.0*A),z2=(-sqrt(delta)-B)/(2.0*A);
    if(z1*z1<z2*z2) return z1;
    return z2;
}

double solve()
{
    double x=0,y=0,z=0,tx=0,ty=0,tz=0,step=1;
    z=getz(x,y);
    while(step>eps)
    {
        for(int i=0;i<8;i++)
        {
            tx=x+dirx[i]*step;
            ty=y+diry[i]*step;
            tz=getz(tx,ty);
            if(tz>=M) continue;
            if(dis(tx,ty,tz)<dis(x,y,z))
            {
                x=tx,y=ty,z=tz;
            }
        }
        step*=sp;
    }
    return dis(x,y,z);
}

int main()
{
    while(scanf("%lf%lf%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f)!=EOF)
    {
        printf("%.8lf\n",solve());
    }
    return 0;
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章