hdu 5058 So easy

So easy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 160    Accepted Submission(s): 104


Problem Description
Small W gets two files. There are n integers in each file. Small W wants to know whether these two files are same. So he invites you to write a program to check whether these two files are same. Small W thinks that two files are same when they have the same integer set.
For example file A contains (5,3,7,7),and file B contains (7,5,3,3). They have the same integer set (3,5,7), so they are same.
Another sample file C contains(2,5,2,5), and file D contains (2,5,2,3).
The integer set of C is (2,5),but the integer set of D is (2,3,5),so they are not same.
Now you are expected to write a program to compare two files with size of n.
 

Input
Multi test cases (about 100). Each case contain three lines. The first line contains one integer n represents the size of file. The second line contains n integers $a_1, a_2, a_3, \ldots, a_n$ - represents the content of the first file. The third line contains n integers $b_1, b_2, b_3, \ldots, b_n$ - represents the content of the second file.
Process to the end of file.
$1 \leq n \leq 100$
$1 \leq a_i , b_i \leq 1000000000$
 

Output
For each case, output "YES" (without quote) if these two files are same, otherwise output "NO" (without quote).
 

Sample Input
3 1 1 2 1 2 2 4 5 3 7 7 7 5 3 3 4 2 5 2 3 2 5 2 5 3 1 2 3 1 2 4
 

Sample Output
YES YES NO NO
 

Source
 


題解及代碼:

      簡單題,用一個map模擬,前n個數的map值記爲1,之後n個數的map值+1,最後判斷是否所有map值都大於2.

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
using namespace std;

map<int,int>m;
map<int,int>::iterator it;

int main()
{
    int n,x;
    while(scanf("%d",&n)!=EOF)
    {
        m.clear();
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            m[x]=1;
        }
        for(int i=0;i<n;i++)
        {
            scanf("%d",&x);
            m[x]++;
        }
        bool flag = true;
        for(it=m.begin();it!=m.end();it++)
        if(it->second<2)
        {
            flag= false;
            break;
        }
        if(flag) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章