bsoj 2044 【SCOI2007】最大土地面積

Description

  在某塊平面土地上有n個點,你可以選擇其中的任意四個點,將這片土地圍起來,當然,你希望這四個點圍成的多邊形面積最大

Input

  第1行一個正整數n,接下來n行,每行2個數x、y,表示該點的橫座標和縱座標。

Output

  最大的多邊形面積,答案精確到小數點後3位。

Sample Input

  5  0 0  1 0  1 1  0 1  0.5 0.5

Sample Output

  1.000

Hint

【數據範圍】

  n<=2000,|x|,|y|<=100000

枚舉對角線時,再枚舉1個點得到對角線與此點的三角形最大面積和最小面積。

一次旋轉卡殼即可算出。。居然在OJ上rank1了呢☺~~~~~~

旋轉卡殼升級版:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct Vector{
 	double x,y;
    Vector operator +(Vector &a){
    	Vector v1;
    	v1.x=this->x+a.x,v1.y=this->y+a.y;
    	return v1;
		};
    Vector operator -(Vector &a){
   	 	Vector v1;
    	v1.x=this->x- a.x,v1.y=this->y -a.y;
	    return v1;
		};
    double operator * (Vector &a){
	    return ((this->x)*a.y)-(a.x*(this->y));
		};
}P[500055] ; 
int n;
int ch[500005];
bool  vis[500005];
int top=0;
bool cmp(Vector a,Vector b){
	return (a.y<b.y)||((a.y==b.y)&&(a.x<b.x));
}
bool Judge(Vector a,Vector b,Vector c){
	Vector q=b-c;
	Vector w=a-c;
	return q*w>=0;
}
double Get_Area(Vector a,Vector b,Vector c){
	a=a-c;
	b=b-c;
	return a*b;
}
double Get_Long(Vector a,Vector b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
void TUBao(){
	sort(P+1,P+1+n,cmp);
	ch[++top]=1;
	int k=2;
	while(k<=n){
		while(top>1&&Judge(P[ch[top]],P[k],P[ch[top-1]]))
		vis[ch[top--]]=0;
		ch[++top]=k;
		vis[k]=1;	
		k++;	
	}
	int Max=top;
	k=n-1;
	while(k>=1){
		while(vis[k])k--;
		while(top>Max&&Judge(P[ch[top]],P[k],P[ch[top-1]]))
		vis[ch[top--]]=0;
		ch[++top]=k;
		vis[k]=1;
		k--; 
	}
}
void Rotating_calipers(){
	int p=2;
	double ans=0.0;
	for(int q=1;q<top;q++){
		while(Get_Area(P[ch[q]],P[ch[q+1]],P[ch[p+1]])>Get_Area(P[ch[q]],P[ch[q+1]],P[ch[p]])){
			p=(p+1)%top;
			if(p==0)p=1;
			}
		double Max=0.0;
		double Min=1e8;
		for(int i=1;i<top;i++)if(i!=q&&i!=p){
		double Temp=Get_Area(P[ch[p]],P[ch[i]],P[ch[q]]);
		Max=max(Max,Temp);
		Min=min(Min,Temp);
		}
		ans=max(ans,Max/2-Min/2);
	}
	printf("%.3lf",ans);
}
int main(){
	scanf("%d",&n);
	for(int i=1;i<=n;i++){
		scanf("%lf%lf",&P[i].x,&P[i].y);
	}
	TUBao();
	Rotating_calipers();
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章