bsoj:1773 -- 【模擬試題】最遠距離點對

1773 -- 【模擬試題】最遠距離點對

Description

  給定平面上的n個點,找出它們之間最遠的點對。

Input

  多組數據,每組第一行n代表點數,接着n行爲點的座標,座標爲整數,不超過Longint範圍。n<=30000。

Output

  每組一行,最遠點對的距離,保留2位小數

Sample Input

  4  0 0  1 1  0 1  1 0

Sample Output

  1.41




第一次旋轉卡殼呢:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
struct Vector{
 	double x,y;
    Vector operator +(Vector &a){
    	Vector v1;
    	v1.x=this->x+a.x,v1.y=this->y+a.y;
    	return v1;
		};
    Vector operator -(Vector &a){
   	 	Vector v1;
    	v1.x=this->x- a.x,v1.y=this->y -a.y;
	    return v1;
		};
    double operator * (Vector &a){
	    return ((this->x)*a.y)-(a.x*(this->y));
		};
}P[500055] ; 
int n;
int ch[500005];
bool  vis[500005];
int top=0;
bool cmp(Vector a,Vector b){
	return (a.y<b.y)||((a.y==b.y)&&(a.x<b.x));
}
bool Judge(Vector a,Vector b,Vector c){
	Vector q=b-c;
	Vector w=a-c;
	return q*w>=0;
}
double Get_Area(Vector a,Vector b,Vector c){
	a=a-c;
	b=b-c;
	return a*b;
}
double Get_Long(Vector a,Vector b){
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
void TUBao(){
	sort(P+1,P+1+n,cmp);
	ch[++top]=1;
	int k=2;
	while(k<=n){
		while(top>1&&Judge(P[ch[top]],P[k],P[ch[top-1]]))
		vis[ch[top--]]=0;
		ch[++top]=k;
		vis[k]=1;	
		k++;	
	}
	int Max=top;
	k=n-1;
	while(k>=1){
		while(vis[k])k--;
		while(top>Max&&Judge(P[ch[top]],P[k],P[ch[top-1]]))
		vis[ch[top--]]=0;
		ch[++top]=k;
		vis[k]=1;
		k--; 
	}
}
void Rotating_calipers(){
	int p=2;
	double ans=0.0;
	for(int q=1;q<top;q++){
		while(Get_Area(P[ch[q]],P[ch[q+1]],P[ch[p+1]])>Get_Area(P[ch[q]],P[ch[q+1]],P[ch[p]]))p=(p+1)%(n+1);
		ans=max(ans,max(Get_Long(P[ch[q]],P[ch[p]]),Get_Long(P[ch[q+1]],P[ch[p+1]])));
	}
	printf("%.2lf",ans);
}
int main(){

	while(scanf("%d",&n)==1){
	for(int i=1;i<=n;i++){
		scanf("%lf%lf",&P[i].x,&P[i].y);
	}
	TUBao();
	Rotating_calipers();
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章