UVa OJ 537 人工智能

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!

So they don't state a problem like ``U=10V, I=5A, P=?" but rather like ``You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There's an electrical current of I=5A through the bulb. Which power is generated in the bulb?".

However, half of the pupils just don't pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: ``Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished."

OK, this doesn't always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)

Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.


Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.

Input 

The first line of the input file will contain the number of test cases.

Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xAU=xV or P=xW, where x is a real number.

Directly before the unit (AV or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:

DataField ::= Concept '=' RealNumber [Prefix] Unit Concept ::= 'P' | 'U' | 'I' Prefix ::= 'm' | 'k' | 'M' Unit ::= 'W' | 'V' | 'A' 

Additional assertions:

  • The equal sign (`=') will never occur in an other context than within a data field.
  • There is no whitespace (tabs,blanks) inside a data field.
  • Either P and UP and I, or U and I will be given.

Output 

For each test case, print three lines:

  • a line saying ``Problem #k" where k is the number of the test case
  • a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
  • a blank line

Sample Input 

3 If the voltage is U=200V and the current is I=4.5A, which power is generated? 
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
 bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage? 

Sample Output 

Problem #1 
P=900.00W 

Problem #2 
I=0.45A

Problem #3 
U=1250000.00V

#include <stdio.h>
#include <string.h>
#define maxn 100

int main()
{
	int t,i,j,p,q;
	int total,flag;
	int len[5],r[5],y[5],vis[5];
	double sum[5],x[5];
	char c;
	char sss[5][100];

	total=1;
	scanf("%d",&t);
	getchar();
	while(t--)
	{
		flag=vis[0]=vis[1]=1;
		p=q=r[0]=r[1]=0;
		memset(sss,'\0',sizeof(sss));
		while((c=getchar())!='\n')//讀取每行給出的問題
		{
			if(c=='=')flag=0;//flag爲檢測到‘=’標誌
			
			else if(!flag&&(c=='W'||c=='V'||c=='A'))//檢測到等號之後,檢測單位並保存,這一步必須在前,否則單位會重複存儲
			{
				sss[q][p++]=c;
				flag=1;//檢測到單位之後,數據保存結束,標誌置1
				len[q++]=p;//保存數據位數
				p=0;//置0,從0開始重新保存下一位
			}
			else if(!flag)//檢測到‘=’之後,保存等號之後的數據
			{
				if(c=='.')//如果有小數點,則進行標記
				{
					vis[q]=0;
					r[q]=p;
				}
				sss[q][p++]=c;
			}
		}
		i=0;
		x[0]=x[1]=1;
		memset(y,0,sizeof(y));
		while(i<2)//每個問題只有兩位數據
		{
			if(sss[i][len[i]-2]=='m')//檢測單位前是否有m
				x[i]=0.001;
			else if(sss[i][len[i]-2]=='M')
				x[i]=1000000;
			else if(sss[i][len[i]-2]=='k')
			    x[i]=1000;

			if(sss[i][len[i]-1]=='A')
				y[i]=6;//y[i]=6標記此項數據爲電流
			else if(sss[i][len[i]-1]=='V')
				y[i]=7;
			else if(sss[i][len[i]-1]=='W')
				y[i]=8;
			i++;
		}
		p=0;
		while(p<2)//每個問題只有兩位數據
		{
			sum[p]=0;
			j=10;//個、十、百
			if(vis[p])//保存的數據沒有小數點
				for(i=0;(sss[p][i]<='9'&&sss[p][i]>='0');i++)
					sum[p]=sum[p]*j+(sss[p][i]-'0');
			else 
			{
				for(i=0,j=10;i<r[p];i++)
					sum[p]=sum[p]*j+(sss[p][i]-'0');
				for(i=r[p]+1;(sss[p][i]<='9'&&sss[p][i]>='0');i++,j*=10)
					sum[p]=sum[p]+(sss[p][i]-'0')*1.0/j;
			}
			sum[p]=sum[p]*x[p];
			p++;
		}
		printf("Problem #%d\n",total++);
		if((y[0]==6&&y[1]==7)||(y[0]==7||y[1]==6))
			printf("P=%.2lfW\n",sum[0]*sum[1]);
		else if(y[0]==6&&y[1]==8)
			printf("U=%.2lfV\n",sum[1]/sum[0]);
		else if(y[0]==7&&y[1]==8)
			printf("I=%.2lfA\n",sum[1]/sum[0]);
		else if(y[0]==8&&y[1]==6)
			printf("U=%.2lfV\n",sum[0]/sum[1]);
		else if(y[0]==8&&y[1]==7)
			printf("I=%.2lfA\n",sum[0]/sum[1]);
		puts("");
	}
	return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章