Cow Contest(Floyd 傳遞閉包)

Cow Contest
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7104   Accepted: 3921

Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ NA ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

 

       題意:

       給出 n(1 ~ 100) 和 m(1 ~ 4500),代表有 n 個結點還有 m 個關係。後給出 m 條關係,每次給出 a 和 b,代表 a > b。問根據這些關係,能最終確定排名的一共有多少個節點。

 

       思路:

       Floyd 傳遞閉包。如果這個結點能確定出第幾,說明經過 Floyd 閉包後,與其他每個結點都會有一個確定的關係,要不就是 你大於我,要不就是 我大於你,如果 Map [ i ] [ j ] 和 Map [ j ] [ i ] 都爲 0 ,說明兩者之間的關係還沒有確定。那麼這個點就不能確定出第幾名。所以最終判斷有多少個結點滿足與除了自己外的所有點都有 Map [ i ] [ j ] || Map [ j ] [ i ] 的即可。

 

       AC:

#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int Map[105][105];
int n;

void floyd () {
    for (int k = 1; k <= n; ++k) {
        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= n; ++j) {
                if (Map[i][k] && Map[k][j])
                    Map[i][j] = 1;
            }
        }
    }
}

int main() {
    int m;

    while (~scanf("%d%d", &n, &m) && (n + m)) {
        memset(Map, 0, sizeof(Map));

        while (m--) {
            int a, b;
            scanf("%d%d", &a, &b);
            Map[a][b] = 1;
        }

        floyd();

        int ans = 0;
        for (int i = 1; i <= n; ++i) {
            int j;
            for (j = 1; j <= n; ++j) {
                if (i == j) continue;
                if (!Map[i][j] && !Map[j][i]) break;
            }

            if (j == n + 1) ++ans;
        }

        printf("%d\n", ans);
    }
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章