FZU Problem 2280 Magic(Hash)

Problem 2280 Magic
Accept: 46 Submit: 150
Time Limit: 2000 mSec Memory Limit : 262144 KB

Problem Description

Kim is a magician, he can use n kinds of magic, number from 1 to n. We use string Si to describe magic i. Magic Si will make Wi points of damage. Note that Wi may change over time.

Kim obey the following rules to use magic:

Each turn, he picks out one magic, suppose that is magic Sk, then Kim will use all the magic i satisfying the following condition:

  1. Wi<=Wk

  2. Sk is a suffix of Si.

Now Kim wondering how many magic will he use each turn.

Note that all the strings are considered as a suffix of itself.

Input

First line the number of test case T. (T<=6)

For each case, first line an integer n (1<=n<=1000) stand for the number of magic.

Next n lines, each line a string Si (Length of Si<=1000) and an integer Wi (1<=Wi<=1000), stand for magic i and it’s damage Wi.

Next line an integer Q (1<=Q<=80000), stand for there are Q operations. There are two kinds of operation.

“1 x y” means Wx is changed to y.

“2 x” means Kim has picked out magic x, and you should tell him how many magic he will use in this turn.

Note that different Si can be the same.

Output

For each query, output the answer.

Sample Input

1
5
abracadabra 2
adbra 1
bra 3
abr 3
br 2
5
2 3
2 5
1 2 5
2 3
2 2
Sample Output

3
1
2
1
題意:n個串和它的價值,兩個操作.1:將x串的價值變成y。2:問以x爲後綴並且價值≤x的串的個數。
題解:Hash預處理每個串O(n^2),o(nq)查詢。
代碼:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<vector>
#include<queue>
#include<set>
#include<algorithm>
#include<map>
using namespace std;
typedef long long int ll;
typedef pair<int,int>pa;
const int N=1e5+10;
const int mod=1e9+7;
const ll INF=1e18;
const int inf=1e4;
int read()
{
    int x=0;
    char ch = getchar();
    while('0'>ch||ch>'9')ch=getchar();
    while('0'<=ch&&ch<='9')
    {
        x=(x<<3)+(x<<1)+ch-'0';
        ch=getchar();
    }
    return x;
}
/***********************************************************/
const int p=131;
int t,n,q,op,x,y;
vector<int>v[1010];
char s[1010][1010];
int len[1010],a[1010];
int f[1010][1010];
int ha[1010];
void init()
{
    ha[0]=1;
    for(int i=1;i<=1000;i++)
        ha[i]=(ll)ha[i-1]*p%mod;
}
int Hash(int x,int l,int r)
{
    return (f[x][r]-(ll)f[x][l-1]*ha[r-l+1]%mod+mod)%mod;
}
void op1()
{
    for(int i=1;i<=n;i++)
    {
        f[i][0]=0;
        for(int j=1;j<=len[i];j++)
            f[i][j]=((ll)f[i][j-1]*p%mod+s[i][j])%mod;
    }
    for(int i=1;i<=n;i++)
    {
        v[i].push_back(i);
        for(int j=i+1;j<=n;j++)
        {
            if(len[i]==len[j])
            {
                if(Hash(i,1,len[i])==Hash(j,1,len[j]))
                {
                    v[i].push_back(j);
                    v[j].push_back(i);
                }
            }
            else if(len[i]>len[j])
            {
                if(Hash(i,len[i]-len[j]+1,len[i])==Hash(j,1,len[j])) v[j].push_back(i);
            }
            else
            {
                if(Hash(i,1,len[i])==Hash(j,len[j]-len[i]+1,len[j])) v[i].push_back(j);
            }
        }
    }
}
int main()
{
    init();
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%s%d",s[i]+1,&a[i]);
            len[i]=strlen(s[i]+1);
            v[i].clear();
        }
        op1();
        scanf("%d",&q);
        while(q--)
        {
            scanf("%d",&op);
            if(op==1)
            {
                scanf("%d%d",&x,&y);
                a[x]=y;
            }
            else
            {
                int sum=0;
                scanf("%d",&x);
                int sz=v[x].size();
                for(int i=0;i<sz;i++)
                {
                    if(a[v[x][i]]<=a[x]) sum++;
                }
                printf("%d\n",sum);
            }
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章