01揹包,Bone Collector

題目:

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

14
 

這是一個最基本的揹包問題,水題一個。。。


代碼:

#include<stdio.h>
#include<string.h>
main()
{
	int f[1010];
	int i;
	int m[1010],w[1010];
	int t;
	int n,V,v;
	scanf("%d",&t);
	for(;t;t--)
	{
		memset(f,0,sizeof(f));
		
		scanf("%d%d",&n,&V);
		for(i=0;i<n;i++)
		{
			scanf("%d",&w[i]);
		}
		for(i=0;i<n;i++)
		{
			scanf("%d",&m[i]);
		}
		for(i=0;i<n;i++)
		{
			for(v=V;v>=m[i];v--)
			{
				if(f[v]<f[v-m[i]]+w[i])
				f[v]=f[v-m[i]]+w[i];
			}
		}
		printf("%d\n",f[V]);
	}
} 




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章