UVA - 1588 Kickdown

A research laboratory of a world-leading automobile company has received an order to create a special transmission mechanism, which allows for incredibly efficient kickdown -- an operation of switching to lower gear. After several months of research engineers found that the most efficient solution requires special gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of the gears. Now they want to perform some experiments to prove their findings.

The first phase of the experiment is done with planar toothed sections, not round-shaped gears. A section of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h . Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom) and one for the driven gear (with teeth at the top).

\epsfbox{p3712a.eps}

There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engaged sections together. The sections are irregular but they may still be put together if shifted along each other.

\epsfbox{p3712b.eps}

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. You need to �nd the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input 

The input file contains several test cases, each of them as described below.

There are two lines in the input, each contains a string to describe a section. The first line describes master section (teeth at the bottom) and the second line describes driven section (teeth at the top). Each character in a string represents one section unit -- 1 for a cavity and 2 for a tooth. The sections can not be flipped or rotated.

Each string is non-empty and its length does not exceed 100.

Output 

For each test case, write to the output a line containing a single integer number -- the minimal length of the stripe required to cut off given sections.

Sample Input 

2112112112 
2212112 
12121212 
21212121 
2211221122 
21212

Sample Output 

10 
8 

15

假設固定裝置s1,那麼裝置s2只要初始狀態左端與s1左端對齊(該狀態用偏移量k=0來標記),然後測試k=0時,兩個裝置是不是”每一位的和都不會超過3“就行了,如果不行就k++,繼續往右邊偏移進行測試。可以知道肯定存在着一個k能使其成立的(也就是s2左端接在s1右端時)。用這種方式遍歷,找到的第一個可行解就是最佳解。 不過上述討論還遺漏了一種組合方式,就是s2也可以往左偏移。其實將上述解法寫成一個fun函數進行封裝,外界(main函數)只要巧妙的利用對稱性,就能重複利用上一段的代碼了。

s1 左或右 s1 (←左移) 右移 s1 s1 左或右 s2

------- ---------- ---------- ---------- -----------

---------- ------------ ---------

s2 s2 s2

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;

bool test(int k,char s1[],char s2[]){
    for(int i = 0; s1[k+i] && s2[i]; i++)
        if(s1[k+i]+s2[i]-2*'0' > 3)return false;
    return true;
}

int fun(char s1[],char s2[]){
    int k = 0;
    while(!test(k,s1,s2))k++;
    return max(strlen(s1),strlen(s2)+k);
}

int main(){
    char bottom[105],top[105];
    while(scanf("%s%s",bottom,top) != EOF)//對稱性
        cout<<min(fun(bottom,top),fun(top,bottom))<<endl;
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章