hdu 3732



Ahui Writes Word

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2245    Accepted Submission(s): 824


Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
 

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
 

Output
Output the maximum value in a single line for each test case.
 

Sample Input
5 20 go 5 8 think 3 7 big 7 4 read 2 6 write 3 5
 

Sample Output
15
Hint
Input data is huge,please use “scanf(“%s”,s)”
 

Author
Ahui
 

Source


做到這道題的時候 又仔細回顧了一遍揹包九講 

 多重揹包 變 01揹包

#include <iostream>
#include <algorithm>
#include <queue>
#include <cstring>
#include <cstdio>
#include <vector>
#include <string>
#include <iterator>
#include <cmath>
#include <deque>
#include <stack>
#include <cctype>
using namespace std;

typedef long long ll;
typedef long double ld;

const int N = 15;
const int INF = 0xfffffff;
const double eps = 1e-8;
const ll MOD = 1e9 + 7;

#define INFL 0x7fffffffffffffffLL
#define met(a, b) memset(a, b, sizeof(a))
#define rep(c, a, b) for (ll c = a; c < b; c++)
#define nre(c, a, b) for (int c = a; c > b; c--)

int res[N][N], dp[11000];

void solve (int v, int c, int n, int m);

int main ()
{
    int n, m;
    while (scanf ("%d%d", &n, &m) != EOF)
    {
        met (res, 0); met (dp, 0);
        char a[20]; int x, y;
        while (n--)
        {
            scanf ("%s%d%d", a, &x, &y);
            res[x][y]++;
        }
        rep (i, 1, 11){
            rep (j, 1, 11) {
                if (res[i][j])
                    solve (i, j, res[i][j], m);
            }

        }
        printf ("%d\n", dp[m]);
    }
    return 0;
}

void solve (int v, int c, int n, int m)
{
    for (int k=1; n>0; k<<=1) //二進制優化
    {
        if (k > n) k = n;
        n -= k;
        int vv = v * k, cc = c * k;
        nre (j, m, cc-1) {
            dp[j] = max (dp[j], dp[j-cc] + vv);
        }
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章