hdu1002 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 166634    Accepted Submission(s): 31864


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
2 1 2 112233445566778899 998877665544332211
 

Sample Output
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 
AC代碼

#include<iostream>
using namespace std;
int main()
{
	int t,i,j,k,m,n,x;
	char str1[1001],str2[1001];
	int a[1001],b[1001],c[1001];
       scanf("%d",&t);
	       k=0;
		while(t--)
		{
          if(k!=0)
			  printf("\n");
		  k++;
		  memset(a,0,sizeof(a));
		  memset(b,0,sizeof(b));
          memset(c,0,sizeof(c));
		  scanf("%s %s",str1,str2);
		  n=strlen(str1);
		  m=strlen(str2);
		  for(j=0,i=n-1;i>=0;i--,j++)
			  a[j]=str1[i]-'0';
          for(j=0,i=m-1;i>=0;i--,j++)
			  b[j]=str2[i]-'0';
		  if(n>m)
			  x=n;
		  else
			  x=m;
		  for(i=0;i<x;i++)
		  {
			  c[i]+=a[i]+b[i];
			   if(c[i]>9)
			  {
				  c[i]-=10;
				  c[i+1]+=1;
			  }
		  }
		   printf("Case %d:\n",k);
printf("%s + %s = ",str1,str2); 
          if(c[i]!=0)
			  printf("%d",c[i]);
		  for(j=i-1;j>=0;j--)
			  printf("%d",c[j]);
		   printf("\n");

		}
	
	return 0;
}

本題爲大數A+B,簡單題!

謝謝閱讀!
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章