hdu oj 2602 Bone Collector(揹包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51860    Accepted Submission(s): 21837


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 
Sample Output
14

題目地址:點擊打開鏈接


AC代碼:
#include<string.h>
#include<math.h>
#include<iostream>
using namespace std;
int n, v, val[1005];
int cost[1005], f[1005];
int main()
{
	int t;scanf("%d", &t);
	while(t--)
	{
		int i, j;
		scanf("%d %d", &n, &v);
		memset(f, 0, sizeof(f));
		for(i = 1; i <= n; i++)
		    scanf("%d", &val[i]);
		for(i = 1; i <= n; i++)
		    scanf("%d", &cost[i]);
		for(i = 1; i <= n; i++)
		{
			for(j = v; j >= cost[i]; j--)
			{
				f[j] = max(f[j], f[j-cost[i]]+val[i]);
			}
		}
		printf("%d\n", f[v]);
	}
	return 0;
}
Sample Output
14
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章