POJ--2063--Investment--揹包

Investment
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 8733   Accepted: 2984

Description

John never knew he had a grand-uncle, until he received the notary's letter. He learned that his late grand-uncle had gathered a lot of money, somewhere in South-America, and that John was the only inheritor. 
John did not need that much money for the moment. But he realized that it would be a good idea to store this capital in a safe place, and have it grow until he decided to retire. The bank convinced him that a certain kind of bond was interesting for him. 
This kind of bond has a fixed value, and gives a fixed amount of yearly interest, payed to the owner at the end of each year. The bond has no fixed term. Bonds are available in different sizes. The larger ones usually give a better interest. Soon John realized that the optimal set of bonds to buy was not trivial to figure out. Moreover, after a few years his capital would have grown, and the schedule had to be re-evaluated. 
Assume the following bonds are available: 
Value Annual
interest
4000
3000
400
250

With a capital of e10 000 one could buy two bonds of $4 000, giving a yearly interest of $800. Buying two bonds of $3 000, and one of $4 000 is a better idea, as it gives a yearly interest of $900. After two years the capital has grown to $11 800, and it makes sense to sell a $3 000 one and buy a $4 000 one, so the annual interest grows to $1 050. This is where this story grows unlikely: the bank does not charge for buying and selling bonds. Next year the total sum is $12 850, which allows for three times $4 000, giving a yearly interest of $1 200. 
Here is your problem: given an amount to begin with, a number of years, and a set of bonds with their values and interests, find out how big the amount may grow in the given period, using the best schedule for buying and selling bonds.

Input

The first line contains a single positive integer N which is the number of test cases. The test cases follow. 
The first line of a test case contains two positive integers: the amount to start with (at most $1 000 000), and the number of years the capital may grow (at most 40). 
The following line contains a single number: the number d (1 <= d <= 10) of available bonds. 
The next d lines each contain the description of a bond. The description of a bond consists of two positive integers: the value of the bond, and the yearly interest for that bond. The value of a bond is always a multiple of $1 000. The interest of a bond is never more than 10% of its value.

Output

For each test case, output – on a separate line – the capital at the end of the period, after an optimal schedule of buying and selling.

Sample Input

1
10000 4
2
4000 400
3000 250

Sample Output

14050

題意:有多個存款方案,每個有兩個屬性值A和B,表示這個方案你要存A塊錢,利息是B塊錢每年,最先輸入的是N和K,你有N的金錢,要求K年後你能得到的最多的金錢數

解析:這個就是普通的完全揹包,不過注意的是數值太大,可以投機取巧,因爲每中方案中存錢數A是1000的倍數,所以可以揹包的下標可以除以1000之後再記錄,但是你可能會想到誤差問題,比如本金是1010,這時候1010/1000=1,別擔心,你想啊,1000和1010存錢有區別麼?這10塊錢有用麼?,存錢方案中都是1000的倍數,所以這些零頭都不用管,到時候加上來就行了,我這裏的做法是:因爲每個利潤都小於10%的,所以我去本金X(110%)^K於是得到最大可能的金錢數,用這個數除以1000當作揹包的最大容量,DP[X]中裝的是存錢爲X塊的時候的利息,這樣我直接完全揹包做完之後,再記錄sum=N+(N+DP[M])+(N+DP[N]+DP[N+DP[N]]).....這樣K次之後就。。。。你會懂的。


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define Max(a,b) a>b?a:b
using namespace std;
int dp[111111];
struct node
{
    int val,interest;
}s[11];
int main (void)
{
    int t,n,m,i,j,k,l,p;
    scanf("%d",&t);
    while(t--&&scanf("%d%d",&m,&l))
    {
        scanf("%d",&n);
        k=m;
        for(i=0;i<l;i++)
        {
            k=1.1*k;	//用K來取m乘以1.1的L次方
        }
        k/=1000;
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&s[i].val,&s[i].interest);
            s[i].val/=1000;	//方案中存錢量除以1000
        }
        memset(dp,0,sizeof(dp));
        for(i=0;i<n;i++)	//直接完全揹包
        for(j=s[i].val;j<=k;j++)
        dp[j]=Max(dp[j],dp[j-s[i].val]+s[i].interest);
        while(l>0)	//求l年後的總利息
        {
            l--;
            m+=dp[m/1000];	//把每年的利息加起來並把M變成那一年的本金繼續求
        }
        printf("%d\n",m);
    }
    return 0;
}

總結:這是把容量根據條件縮小的一種做法,在做題的時候要根據已知條件充分挖掘一切可以簡化的方法,有些時候這題目考的就是這個,就像這題一樣,不會這麼簡化的話,你就等着GG到死吧。。。


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章