POJ3186 Treats for the Cows (區間DP)

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
The treats are numbered 1…N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2…N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint

Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43

題意:
給出的一系列的數字,可以看成一個雙向隊列,每次只能從隊首或者隊尾出隊,第n個出隊就拿這個數乘以n,最後將和加起來,求最大和

思路:
一開始想用貪心,但兩邊相等的情況不知道怎麼搞。
區間DP,從內向外推

dp[i][j]dp[i][j]iijj區間內的最大價值
dp[i][j]=max(dp[i][j1]+a[j]age,dp[i+1][j]+a[i]age)dp[i][j] = \max(dp[i][j-1] + a[j] * age, dp[i+1][j] + a[i] * age)
其中 age = n-j+i ,即第n-j+i個取的

#include<cstdio>
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[2005][2005];
int a[2005];

int main()
{
    int n;
    scanf("%d", &n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d", &a[i]);
        dp[i][i] = a[i] * n;
    }
    for(int i=n-1;i>=1;i--)
    {
        for(int j=i+1;j<=n;j++)
        {
            int age = n-j+i;
            dp[i][j] = max(dp[i][j-1] + a[j] * age, dp[i+1][j] + a[i] * age);
        }
    }
    cout << dp[1][n] << endl;
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章