HDU1036 Average is not Fast Enough!(java)

Problem Description
A relay is a race for two or more teams of runners. Each member of a team runs one section of the race. Your task is to help to evaluate the results of a relay race.

You have to process several teams. For each team you are given a list with the running times for every section of the race. You are to compute the average time per kilometer over the whole distance. That’s easy, isn’t it?
So if you like the fun and challenge competing at this contest, perhaps you like a relay race, too. Students from Ulm participated e.g. at the “SOLA” relay in Zurich, Switzerland. For more information visit http://www.sola.asvz.ethz.ch/ after the contest is over.

Input
The first line of the input specifies the number of sections n followed by the total distance of the relay d in kilometers. You may safely assume that 1 <= n <= 20 and 0.0 < d < 200.0. Every following line gives information about one team: the team number t (an integer, right-justified in a field of width 3) is followed by the n results for each section, separated by a single space. These running times are given in the format “h:mm:ss” with integer numbers for the hours, minutes and seconds, respectively. In the special case of a runner being disqualified, the running time will be denoted by “-:–:–”. Finally, the data on every line is terminated by a newline character. Input is terminated by EOF.

Output
For each team output exactly one line giving the team’s number t right aligned in a field of width 3, and the average time for this team rounded to whole seconds in the format “m:ss”. If at least one of the team’s runners has been disqualified, output “-” instead. Adhere to the sample output for the exact format of presentation.

Sample Input
2 12.5
5 0:23:21 0:25:01
42 0:23:32 -:–:–
7 0:33:20 0:41:35

Sample Output
5: 3:52 min/km
42: -
7: 6:00 min/km

題意是求平均速度,注意符號處理、四捨五入即可!
上一篇提到使用System.out.printf(),oj會報錯,這次我把裏面\n拿到外面就可以了!

import java.util.Scanner;

public class P1036 {

    public static void main(String[] args) {
        new P1036().run();
    }

    public void run() {
        Scanner scanner = new Scanner(System.in);
        int n = scanner.nextInt();
        double d = scanner.nextDouble();
        String[] time = new String[n];
        int num;
        boolean flag = false;
        int v = 0;
        while (scanner.hasNextInt()) {
            num = scanner.nextInt();
            flag = false;
            for (int i = 0; i < n; i++) {
                time[i] = scanner.next();
                if (time[i].contains("-")) {
                    flag = true;
                }
            }
            if(flag == false){
                int times = 0;
                for (int i = 0; i < time.length; i++) {
                    times += getSecond(time[i]);
                }
                v = (int) (times / d + 0.5);    //4舍5入
            }
            if (flag) {
                System.out.printf("%3d: -", num);
                System.out.println();
            } else {
                System.out.printf("%3d: %d:%02d min/km", num, v / 60, v % 60);
                System.out.println();
            }
        }
        scanner.close();
    }

    /**
     * time 00:00:00
     */
    public int getSecond(String time) {
        String[] times = time.split(":");

        return Integer.parseInt(times[0]) * 3600 + Integer.parseInt(times[1])
                * 60 + Integer.parseInt(times[2]);
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章