HDU1039 Easier Done Than Said?(java)

Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate “pronounceable” passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it’s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee’ or ‘oo’.

(For the purposes of this problem, the vowels are ‘a’, ‘e’, ‘i’, ‘o’, and ‘u’; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end’ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end

Sample Output
is acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is not acceptable.
is acceptable.
is acceptable.

簡單的字符串處理題

import java.util.Scanner;

public class P1039 {

    public static void main(String[] args) {
        new P1039().run();
    }

    public void run() {
        Scanner scanner = new Scanner(System.in);
        String str;
        while (!(str = scanner.next()).equals("end")) {
            if (isMeet1(str) && isMeet2(str) && isMeet3(str)) {
                System.out.printf("<%s> is acceptable.", str);
                System.out.println();
            }else {
                System.out.printf("<%s> is not acceptable.", str);
                System.out.println();
            }
        }
        scanner.close();
    }

    public boolean isVowel(char c) {
        if (c == 'a' || c == 'e' || c == 'i' || c == 'u' || c == 'o')
            return true;
        else
            return false;
    }

    public boolean isMeet1(String str){
        for (int i = 0; i < str.length(); i++) {
            if (isVowel(str.charAt(i))) {
                return true;
            }
        }
        return false;
    }

    public boolean isMeet2(String str){
        for (int i = 0; i < str.length() - 2; i++) {
            if(isVowel(str.charAt(i) ) && isVowel(str.charAt(i + 1))
                    && isVowel(str.charAt(i + 2))){
                return false;
            }else if(!isVowel(str.charAt(i) ) && !isVowel(str.charAt(i + 1))
                    && !isVowel(str.charAt(i + 2))){
                return false;
            }
        }
        return true;
    }

    public boolean isMeet3(String str){
        for (int i = 0; i < str.length() - 1; i++) {
            if(str.charAt(i) == str.charAt(i + 1) &&
                    str.charAt(i) != 'e' &&
                    str.charAt(i) != 'o'){
                return false;
            }
        }
        return true;
    }

}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章