PAT Advanced 1003 Emergency

Emergency

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

題目大意

本題是一道最短路徑的問題,給定點的數量n,邊數量m,起點st, 終點des,對應每個點都有固定的權值,找到由起點到中終點的最短路徑的條數,並輸出在最短路徑中權值最大的值

解題思路

本題主要是dijkstra算法的使用,在基礎上需要求出路徑的條數,並求出可選路徑中最大的權值,需要添加 nums數組表示到當前點的路徑條數,w數組表示到每個點的最大權值

解題代碼

#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

const int N = 510, INF = 0x3f3f3f3f;
int g[N][N], dist[N], w[N];
int wei[N], nums[N];
bool vis[N];

int n, m, st, des;
void dijkstra(int s){
    memset(dist, 0x3f, sizeof dist);
    dist[s] = 0, nums[s] = 1, w[s] = wei[s];
    for (int i = 0; i < n; i ++){
        int t = -1;
        for (int j = 0; j < n; j++)
            if (!vis[j] && (t == -1 || dist[t] > dist[j]))
                t = j;
        for (int j = 0; j < n; j++){
            if (dist[j] > dist[t] + g[t][j]){
                dist[j] = dist[t] + g[t][j];
                w[j] = w[t] + wei[j];
                nums[j] = nums[t];
            } else if (dist[j] == dist[t] + g[t][j]){
                if (w[j] < w[t] + wei[j]) w[j] = w[t] + wei[j];
                nums[j] += nums[t];
            }
        }
        vis[t] = true;
    }
}
int main(){
    scanf("%d %d %d %d", &n , &m, &st, &des);
    memset(g, 0x3f, sizeof g);
    for (int i = 0 ; i < n; i++) scanf("%d", &wei[i]);
    while (m --){
        int a, b, c;
        scanf("%d %d %d", &a, &b, &c);
        g[a][b] = g[b][a] = c;
    }
    dijkstra(st);
    printf("%d %d", nums[des], w[des]);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章