PAT甲級真題 1046 Shortest Distance (20分) C++實現 (環形兩點間最小距離,找基準點)

題目

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

思路

一開始用了笨方法,記錄各段距離,每次求兩點距離時都累加一遍,複雜度O(mn),最後一個測試點果斷超時……

後參考了柳神的方法:以0號節點爲基準,用dist[i]表示每個節點到0號的距離,dist[0] = 0,這樣可以直接用dist[i] - dist[j]求出j到i的距離。由於是環形,距離只有正向反向兩種可能,二者和是周長,計算出一邊的距離lenmin{len, sum-len}即爲所求,複雜度O(n)。

代碼

#include <iostream>
#include <vector>
using namespace std;

int main(){
    int n;
    cin >> n;
    vector<int> dist(n+1);
    int sum = 0;  //周長
    for(int i = 1; i <= n; i++){
        int d;
        cin >> d;
        sum += d;
        dist[i] = sum;
    }

    int m;
    cin >> m;
    for(int i = 0; i < m; i++){
        int s, t;
        cin >> s >> t;
        if (s > t){
            swap(s, t);
        }
        int len = dist[t-1] - dist[s-1];
        cout << min(len, sum - len) << endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章