UVA11631 HDU2988 Dark roads【最小生成樹+Kruskal算法】

Dark roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1519 Accepted Submission(s): 664

Problem Description
Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?

Input
The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 231.

Output
For each test case print one line containing the maximum daily amount the government can save.

Sample Input
7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0

Sample Output
51

Source
2009/2010 Ulm Local Contest

問題鏈接UVA11631 HDU2988 Dark roads
問題簡述:政府爲了減小開支決定關閉一些路燈,需要保證照亮的路能連接所有路口,計算可以關多少燈?
問題分析
    經典最小生成樹MST問題,用Kruskal算法來解決,需要用到並查集。
    程序中,圖的表示比較經典,用向量vector存儲圖是比較簡單的。也可以用邊列表的數組來表示圖。
程序說明:(略)
參考鏈接:(略)
題記:(略)

AC的C++語言程序如下:

/* UVA11631 HDU2988 Dark roads */

#include <bits/stdc++.h>

using namespace std;

const int N = 200000;
int f[N];
void UFInit(int n)
{
    for(int i = 0; i < n; i++)
        f[i] = i;
}

int Find(int a) {
    return a == f[a] ? a : f[a] = Find(f[a]);
}

int main()
{
    int n, m;
    while(~scanf("%d%d", &n, &m) && (n || m)) {
        int totw = 0, u, v, w;
        vector<pair<int, pair<int, int> > > g;
        for(int i = 0; i < m; i++) {
            scanf("%d%d%d", &u, &v, &w);
            totw += w;
            g.push_back(make_pair(w, make_pair(u, v)));
        }

        sort(g.begin(), g.end());

        UFInit(n);

        int cost = 0;
        for(int i = 0; i < (int)g.size(); i++) {
            w = g[i].first;
            u = g[i].second.first;
            v = g[i].second.second;
            u = Find(u);
            v = Find(v);
            if(u != v) {
                cost += w;
                f[v] = u;
            }
        }

        printf("%d\n", totw - cost);
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章