UVA10007 HDU1131 Count the Trees【卡特蘭數+大數】

Count the Trees

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2733 Accepted Submission(s): 1670

Problem Description
Another common social inability is known as ACM (Abnormally Compulsive Meditation). This psychological disorder is somewhat common among programmers. It can be described as the temporary (although frequent) loss of the faculty of speech when the whole power of the brain is applied to something extremely interesting or challenging.
Juan is a very gifted programmer, and has a severe case of ACM (he even participated in an ACM world championship a few months ago). Lately, his loved ones are worried about him, because he has found a new exciting problem to exercise his intellectual powers, and he has been speechless for several weeks now. The problem is the determination of the number of different labeled binary trees that can be built using exactly n different elements.

For example, given one element A, just one binary tree can be formed (using A as the root of the tree). With two elements, A and B, four different binary trees can be created, as shown in the figure.
在這裏插入圖片描述
If you are able to provide a solution for this problem, Juan will be able to talk again, and his friends and family will be forever grateful.

Input
The input will consist of several input cases, one per line. Each input case will be specified by the number n ( 1 ≤ n ≤ 100 ) of different elements that must be used to form the trees. A number 0 will mark the end of input and is not to be processed.

Output
For each input case print the number of binary trees that can be built using the n elements, followed by a newline character.

Sample Input
1
2
10
25
0

Sample Output
1
4
60949324800
75414671852339208296275849248768000000

Source
UVA

問題鏈接UVA10007 HDU1131 Count the Trees
問題簡述:計算n個結點的二叉樹的個數.
問題分析:n個結點形成的二叉樹的總數是卡特蘭數與階乘的乘積C[n]*n!。
程序說明:(略)
參考鏈接:(略)
題記:(略)

AC的Java語言程序如下:

/* UVA10007 HDU1131 Count the Trees */ 

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
	public static void main(String args[]) throws Exception {
		BigInteger[] c = new BigInteger[300 + 1];
		BigInteger[] f = new BigInteger[300 + 1];
		c[1] = BigInteger.ONE;
		f[1] = BigInteger.ONE;
		for(int i= 2; i <= 300; i++) {
			c[i] = c[i - 1].multiply(BigInteger.valueOf(4 * i - 2)).divide(BigInteger.valueOf(i + 1));
			f[i] = f[i - 1].multiply(BigInteger.valueOf(i));
		}

		Scanner in = new Scanner(System.in);
	        while(true) {
			int n = in.nextInt();
			if(n == 0) break;
			System.out.println(c[n].multiply(f[n]));
		}
	}
}

AC的C++語言程序如下:

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章