HDU2266 How Many Equations Can You Find【DFS】

How Many Equations Can You Find

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1723 Accepted Submission(s): 1148

Problem Description
Now give you an string which only contains 0, 1 ,2 ,3 ,4 ,5 ,6 ,7 ,8 ,9.You are asked to add the sign ‘+’ or ’-’ between the characters. Just like give you a string “12345”, you can work out a string “123+4-5”. Now give you an integer N, please tell me how many ways can you find to make the result of the string equal to N .You can only choose at most one sign between two adjacent characters.

Input
Each case contains a string s and a number N . You may be sure the length of the string will not exceed 12 and the absolute value of N will not exceed 999999999999.

Output
The output contains one line for each data set : the number of ways you can find to make the equation.

Sample Input
123456789 3
21 1

Sample Output
18
1

Author
dandelion

Source
HDU 8th Programming Contest Online

問題鏈接HDU2266 How Many Equations Can You Find
問題簡述:給定一個只包含0-9數字的字符串,在字符之間添加“+”或“-”符號。例如字符串“12345”,可以有一個字符串“123+4-5”。同時,給定一個整數N,計算有多少種方法使加上“+”或“-”符號字符串後結果等於N。
問題分析:用DFS實現,窮盡搜索。
程序說明:(略)
參考鏈接:(略)
題記:(略)

AC的C++語言程序如下:

/* HDU2266 How Many Equations Can You Find */

#include <bits/stdc++.h>

using namespace std;

typedef long long LL;

string s;
LL n, ans;

void dfs(int k, LL num)
{
    if(s[k] == '\0') {
        if(num == n) ans++;
    } else {
        LL tmp = 0;
        for(int i = k; s[i]; i++) {
            tmp = tmp * 10 + s[i] - '0';
            dfs(i + 1, num + tmp);
            if(k) dfs(i + 1, num - tmp);        // 首個數前不可帶符號
        }
    }
}

int main()
{
    while(cin >> s >> n) {
        ans = 0;
        dfs(0, 0);
        cout << ans << endl;
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章