1069 The Black Hole of Numbers (20分)

1069 The Black Hole of Numbers (20分)

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:
Each input file contains one test case which gives a positive integer N in the range (0,10 ^​4​​ ).

Output Specification:
If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

本題思路:程序結束只有兩種情況:1、一開始四個數相同 2、最後得到6174,分開判斷即可。不要忘記輸出時%04d

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;

int a[4]={0,0,0,0};
int d,x,n;
bool cmp(int a,int b)
{
    return a>b;
}

int main()
{
    string str;
    cin >> str;
    for(int i=0;i<str.size();i++)
        a[i]=str[i]-'0';
    if(a[0]==a[1]&&a[1]==a[2]&&a[3]==a[2])
        cout << str << " - " << str << " = " << "0000";
    else
    {
        while(n!=6174)
        {
            sort(a,a+4,cmp);
            for(int i=0;i<4;i++)
            {
                d=d*10+a[i];
                x=x*10+a[3-i];
            }
            n=d-x;
            printf("%04d - %04d = %04d\n",d,x,n);
            d=0;x=0;
            int t=n;
            for(int i=0;i<4;i++)
            {
                a[i]=t%10;
                t/=10;
            }
        }
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章