1046 Shortest Distance (20分) (含測試點2分析)

1046 Shortest Distance (20分)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:
Each input file contains one test case. For each case, the first line contains an integer N (in [3,10 ^​5​​ ]), followed by N integer distances D​1​​ D​2​​ ⋯ D​N​​ , where D​i​​ is the distance between the i-th and the (i+1)-st exits, and D​N​​ is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10 ^​4​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10 ^​7
​​ .

Output Specification:
For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7

測試點2問題:如果每次給兩個點時都遍歷一遍計算兩點之間的距離,這種情況複雜度過高會導致TLE,因此針對這種情況可以用前綴和,先預處理距離和,再通過前綴和公式計算距離可以將時間複雜度有效降低

#include<iostream>
#include<algorithm>

using namespace std;

int n,t;
int sum;
int l[100010];  //保存題目給的距離的數組
int PrefixSum[100010]; //前綴和數組
int main() 
{
    cin >> n;
    for(int i=1;i<=n;i++)
    {
        cin >> l[i];
        sum+=l[i]; //計算整個環的總距離
    }
    for(int i=1;i<=n;i++)
        PrefixSum[i]=PrefixSum[i-1]+l[i];  //前綴和處理
    cin >> t;
    for(int i=0;i<t;i++)
    {
        if(i!=0)
            printf("\n");
        int x,y;
        cin >> x >> y;
        if(x>y)
            swap(x,y);
        int res=PrefixSum[y-1]-PrefixSum[x-1];
        if(res>sum-res)
            res=sum-res;
        printf("%d",res);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章