LightOJ 1245 Harmonic Number (II)

LightOJ 1245 Harmonic Number (II)

I was trying to solve problem ‘1234 - Harmonic Number’, I wrote the following code

long long H( int n ) {
long long res = 0;
for( int i = 1; i <= n; i++ )
res = res + n / i;
return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n(1n<231).n (1 ≤ n < 2^{31}).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11
1
2
3
4
5
6
7
8
9
10
2147483647

Sample Output

Case 1: 1
Case 2: 3
Case 3: 5
Case 4: 8
Case 5: 10
Case 6: 14
Case 7: 16
Case 8: 20
Case 9: 23
Case 10: 27
Case 11: 46475828386

除法分塊模板題,AC代碼如下:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int main(){
    ll n,t;
    cin>>t;
    for(ll i=1;i<=t;i++){
        cin>>n;
        ll ans=0;
        for(ll j=1,k;j<=n;j=k+1){
            k=n/(n/j);
            ans+=ll(k-j+1)*ll(n/j);
        }
        cout<<"Case "<<i<<": "<<ans<<endl;
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章