有關凸包求解的問題

計算幾何——凸包總結
問題的描述:
二維平面內,給定N個散亂的點,求一個最小凸邊形(凸包),使得N個點都不在凸多邊形外。 
解決方法2:Andrew 算法
1.找出座標最小的點。首先按照x座標大小或y座標大小進行排序(如果x座標一樣,y座標就從小到大排序或如果y座標一樣,x座標就從小到大排序)
2.Andrew算法的主要思路:分成兩次求凸包,先從左到右一遍,再從右到左一遍(或先下到上一遍,再從上到下一遍)。
3.進行叉乘進行判斷。向量a與向量b進行叉乘,如果結果爲正則a在b的右邊,反之在左邊。

 Wall  POJ - 1113

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 


Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

結果四捨五入就可以了

 

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<math.h>
using namespace std;
double pi=acos(-1.0);
struct node
{
    double x;
    double y;
} q[1010];
node p[1010];
int r,cnt;
int mult(node a,node b,node c)
{
    return (b.x-a.x)*(c.y-a.y)-(c.x-a.x)*(b.y-a.y);
}
void Andrew(int n)
{
    r=0;
    for(int i=0; i<n; i++)
    {
        while(r>1&&mult(p[r-2],p[r-1],q[i])<=0)
            r--;
        p[r++]=q[i];
    }
    cnt=r;
    for(int i=n-1; i>=0; i--)//
    {
        while(r>cnt&&mult(p[r-2],p[r-1],q[i])<=0)
            r--;
        p[r++]=q[i];
    }
}
int cmp(node a,node b)
{
    if(a.x==b.x)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{

    int n,l;
    while(~scanf("%d%d",&n,&l))
    {
        for(int i=0; i<n; i++)
            scanf("%lf%lf",&q[i].x,&q[i].y);
        sort(q,q+n,cmp);
        Andrew(n);
        double ans=2*pi*l;
        for(int i=1; i<r; i++)
            ans+=sqrt((p[i].x-p[i-1].x)*(p[i].x-p[i-1].x)+(p[i].y-p[i-1].y)*(p[i].y-p[i-1].y));
        printf("%.0f\n",ans);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章