M - Sekiro

Sekiro: Shadows Die Twice is an action-adventure video game developed by FromSoftware and published by Activision. In the game, the players act as a Sengoku period shinobi known as Wolf as he attempts to take revenge on a samurai clan who attacked him and kidnapped his lord.

As a game directed by Hidetaka Miyazaki, Sekiro (unsurprisingly) features a very harsh death punishment. If the player dies when carrying gg amount of money, the amount of money will be reduced to \left\lceil \frac{g}{2} \right\rceil⌈
2
g

⌉, where \left\lceil \frac{g}{2} \right\rceil⌈
2
g

⌉ indicates the smallest integer g’g

that 2g’ \ge g2g

≥g.

As a noobie of the game, BaoBao has died kk times in the game continuously. Given that BaoBao carried nn amount of money before his first death, and that BaoBao didn’t collect or spend any money during these kk deaths, what’s the amount of money left after his kk deaths?

Input
There are multiple test cases. The first line of the input contains an integer TT (about 10^310
3
), indicating the number of test cases. For each test case:

The first and only line contains two integers nn and kk (0 \le n \le 10^90≤n≤10
9
, 1 \le k \le 10^91≤k≤10
9
), indicating the initial amount of money BaoBao carries and the number of times BaoBao dies in the game.

Output
For each test case output one line containing one integer, indicating the amount of money left after kk deaths.

Sample Input
4
10 1
7 1
10 2
7 2
Sample Output
5
4
3
2
Hint
For the third sample test case, when BaoBao dies for the first time, the money he carries will be reduced from 10 to 5; When he dies for the second time, the money he carries will be reduced from 5 to 3.
注意:如果n=1或者0的時候,就要退出循環,因爲1/2再向上取整,一直爲1
一直對n/2,如果是奇數就是n/2+1,如果是偶數則爲n/2

#include<bits/stdc++.h>
using namespace std;

int main()
{
    std::ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--)
    {
        int n,k;
        cin>>n>>k;
        while(k)
        {
            if(n%2==0)
                n=n/2;
            else
                n=n/2+1;
            if(n==1||n==0)
                break;
            k--;
        }
        cout<<n<<endl;
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章