PAT 1056 Mice and Rice

1056 Mice and Rice (25分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

題意很難懂啊,,,還是英語不行

o(╥﹏╥)o

題意:n個人分成m組,第二行輸出 n 個人的 體重 , 第三行是 n個人編號的順序,分成n組,每次比較體重,最大的繼續下一輪的比較,沒有贏得就淘汰。每個人排名 是 當前分的 組數 + 1

比如:樣例中:608 爲一組 6號的體重是19,0號是25,8號是57,8號獲勝進入下一輪

用隊列進行模擬即可

#include <bits/stdc++.h>
using namespace std;
struct node{
	int weight, ind0, ind1, rank;
};
bool cmp(node a, node b){
	return a.ind0 < b.ind0;
}

int main(){
	int n, g, num;
	scanf("%d%d", &n, &g);
	vector<int> v(n);
	vector<node> w(n);
	for(int i = 0; i < n; i++){
		scanf("%d", &v[i]);
	}
	for(int i = 0; i < n; i++){
		scanf("%d", &num);
		w[i].weight = v[num];
		w[i].ind1 = i;
		w[i].ind0 = num;
	}
	queue<node> q;
	for(int i = 0; i < n; i++){
		q.push(w[i]);
	}
	while(!q.empty()){
		int size = q.size();
		if(size == 1){
			node temp = q.front();
			w[temp.ind1].rank = 1;
			break;
		}
		int group = size / g;
		if(size % g != 0){
			group++;
		}
		node maxnode;
		int cnt = 0, max = -1;
		for(int i = 0; i < size; i++){
			node temp = q.front();
			w[temp.ind1].rank = group + 1;
			q.pop();
			cnt++;
			if(temp.weight > max){
				maxnode = temp;
				max = temp.weight;
			}
			if(cnt == g || i == size - 1){
				cnt = 0;
				max = -1;
				q.push(maxnode);
			}
		}
	}
	sort(w.begin(), w.end(), cmp);
	for(int i = 0; i < n; i++){
		if(i != 0) printf(" ");
		printf("%d", w[i].rank);
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章