PAT 1129 Recommendation System

1129 Recommendation System (25分)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

 這道題,單看英文確實題意確實不太好理解,最後根據樣例才把這道題看懂……

題目大意:

實現一個簡單的推薦系統的功能。用戶在看第一個的時候不推薦任何數字,因爲之前沒有看過任何數字。之後,推薦的數字按照用戶之前看過的數字的個數來推薦,次數大的優先輸出,如果次數一樣,那麼數字小的優先輸出。

第一行給出的n和k分別表示查看數字的總次數,和推薦數字的最多個數(一次最多推薦k個)。

 

解決方法:利用結構體和set。結構體實現數據的封裝,利用set對數據排序,修改數據的次數也很方便。

#include <bits/stdc++.h>
#define Max 55555
using namespace std;
struct node{
	int num, cnt;
	node(int num,int cnt):num(num),cnt(cnt){}
	bool operator < (const node &a) const{
		return cnt != a.cnt ? cnt > a.cnt : num < a.num;
	}
};
set<node> s;
int times[Max], n, k, num;
int main(){
	memset(times, 0, sizeof(times));
	cin >> n >> k;
	
	for(int i = 0; i < n; i++){
		cin >> num;
		if(i != 0){
			cout << num << ":";
			int cnt = 0;
			set<node> ::iterator it;
			for(it = s.begin(); cnt < k && it!=s.end(); it++){
				cout << " " << (*it).num;
				cnt++;
			}
			cout << endl;
		}
		set<node> ::iterator it;
		it = s.find(node(num,times[num]));
		if(it != s.end()) s.erase(it);
		times[num]++;//更新瀏覽次數 加入set中
		s.insert(node(num,times[num])); 
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章