2018杭電多校day1_A Maximum Multiple HDU - 6298

Maximum Multiple

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2606    Accepted Submission(s): 1091


 

Problem Description

Given an integer n , Chiaki would like to find three positive integers x , y and z such that: n=x+y+z , x∣n , y∣n , z∣n and xyz is maximum.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106 ), indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤106 ).

 

 

Output

For each test case, output an integer denoting the maximum xyz . If there no such integers, output −1 instead.

 

 

Sample Input

3 1 2 3

 

Sample Output

-1 -1 1

 

Source

2018 Multi-University Training Contest 1

隊友找的規律 任意數分三份若要使三個數乘積最大,即需要三個數儘可能接近

故劃分爲1/3,1/3,1/3或者1/2,1/4,1/4.只需討論情況即可

#include<bits/stdc++.h>

#define ms(a,x) memset(a,x,sizeof(a))
using namespace std;

#define N 200
#define MAX 2000000

typedef long long ll;
int main(){
	int t;
	scanf("%d",&t);
	for(int i=0;i<t;i++){
		int n;
		scanf("%d",&n);
		if(n%3==0)printf("%lld\n",1ll*n*n*n/27);
		else if(n%4==0)printf("%lld\n",1ll*n*n*n/32);
		else puts("-1");
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章