Nasty Hacks

                       Nasty Hacks

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 872 Accepted Submission(s): 589

Problem Description
You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use
to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.


Input
The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.

Output
Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.

Sample Input
3
0 100 70
100 130 30
-100 -70 40

Sample Output
advertise
does not matter
do not advertise

Source
Nordic 2006

Recommend
zty

#include <iostream>
using namespace
std;
int
main()
{

   int
a,b,c,t;
   cin>>t;
   while
(t--)
   {

cin>>a>>b>>c;
if
(b>a+c)
cout<<"advertise"<<endl;
else if
(b==a+c)
cout<<"does not matter"<<endl;
else

cout<<"do not advertise"<<endl;

   }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章