hdu 5748 Bellovin (最長遞增子序列 二分查找)

題目鏈接:hdu 5748

Bellovin

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Problem Description
Peter has a sequence a1,a2,…,an and he define a function on the sequence – F(a1,a2,…,an)=(f1,f2,…,fn), where fi is the length of the longest increasing subsequence ending with ai.

Peter would like to find another sequence b1,b2,…,bn in such a manner that F(a1,a2,…,an) equals to F(b1,b2,…,bn). Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,…,an is lexicographically smaller than sequence b1,b2,…,bn, if there is such number i from 1 to n, that ak = bk for 1 ≤ k < i and ai < bi.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤100000) – the length of the sequence. The second line contains n integers a1,a2,…,an (1≤ai≤109).

Output
For each test case, output n integers b1,b2,…,bn (1≤bi≤109) denoting the lexicographically smallest sequence.

Sample Input
3
1
10
5
5 4 3 2 1
3
1 3 5

Sample Output
1
1 1 1 1 1
1 2 3

題面要求最小字典序,其實就是求最長遞增子序列的長度,所求即爲f1,f2,f3…。

直接敲dp的時間複雜度是n ^ 2,會T掉,因此考慮時間複雜度爲nlogn的二分寫法。

#include <cstdio>
#include <string>
#include <cstring>
#include <algorithm>
#define MAX 100005
#define INF -0x7f7f7f7f

using namespace std;

int ans[MAX];
int arr[MAX];
int tmp[MAX];
int R = 0;

int middle(int i)//二分
{
    int l = 1, r = R, mid;
    if(arr[i] > tmp[r])
    {
        tmp[++R] = arr[i];
        return R;
    }
    else if(arr[i] <= tmp[1])
    {
        tmp[1] = arr[i];
        return 1;
    }
    while(l < r)
    {
        mid = (l + r) / 2;
        if(arr[i] > tmp[mid])
            l = mid + 1;//這裏不加1可能會陷入無限循環中。
        else if(arr[i] < tmp[mid])
            r = mid;
        else
            return mid;
    }
    tmp[r] = arr[i];
    return r;
}

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        R = 0;
        tmp[R] = 0;
        int n;
        scanf("%d", &n);
        for(int i = 0; i < n; i++)  scanf("%d", &arr[i]);

        for(int i = 0; i < n; i++)
        {
            ans[i] = middle(i);
        }

        for(int i = 0; i < n; i++)
            if(i < n - 1)
                printf("%d ", ans[i]);
            else
                printf("%d\n", ans[i]);
    }
    return 0;
}

運行結果:
這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章