18冬第二題 PAT甲級 1153 Decode Registration Card of PAT (25分) 雞賊的題

題目

A registration card number of PAT consists of 4 parts:

  • the 1st letter represents the test level, namely, T for the top level, A for advance and B for basic;
  • the 2nd - 4th digits are the test site number, ranged from 101 to 999;
  • the 5th - 10th digits give the test date, in the form of yymmdd;
  • finally the 11th - 13th digits are the testee's number, ranged from 000 to 999.

Now given a set of registration card numbers and the scores of the card owners, you are supposed to output the various statistics according to the given queries.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (≤10​4​​) and M (≤100), the numbers of cards and the queries, respectively.

Then N lines follow, each gives a card number and the owner's score (integer in [0,100]), separated by a space.

After the info of testees, there are M lines, each gives a query in the format Type Term, where

  • Type being 1 means to output all the testees on a given level, in non-increasing order of their scores. The corresponding Term will be the letter which specifies the level;
  • Type being 2 means to output the total number of testees together with their total scores in a given site. The corresponding Term will then be the site number;
  • Type being 3 means to output the total number of testees of every site for a given test date. The corresponding Term will then be the date, given in the same format as in the registration card.

Output Specification:

For each query, first print in a line Case #: input, where # is the index of the query case, starting from 1; and input is a copy of the corresponding input query. Then output as requested:

  • for a type 1 query, the output format is the same as in input, that is, CardNumber Score. If there is a tie of the scores, output in increasing alphabetical order of their card numbers (uniqueness of the card numbers is guaranteed);
  • for a type 2 query, output in the format Nt Ns where Nt is the total number of testees and Ns is their total score;
  • for a type 3 query, output in the format Site Nt where Site is the site number and Nt is the total number of testees at Site. The output must be in non-increasing order of Nt's, or in increasing order of site numbers if there is a tie of Nt.

If the result of a query is empty, simply print NA.

Sample Input:

8 4
B123180908127 99
B102180908003 86
A112180318002 98
T107150310127 62
A107180908108 100
T123180908010 78
B112160918035 88
A107180908021 98
1 A
2 107
3 180908
2 999

Sample Output:

Case 1: 1 A
A107180908108 100
A107180908021 98
A112180318002 98
Case 2: 2 107
3 260
Case 3: 3 180908
107 2
123 2
102 1
Case 4: 2 999
NA

雞賊之處

1.准考證帶字母
只能用string存准考證,所以還得弄個結構體,存准考證和分數

2.要求排序
就因爲這個排序,一定要用結構體和vector,在自定義一個排序函數

3.收集、計算
如果是收集(查詢1),那隻用結構體和vector沒有問題。
如果是計算(查詢3),因爲結構體和vector的成員值是隻讀的(我試過了,成員值只能局部改,出了框改不了),只能用map。而map會超時(很慘了),所以只能用unodered_map了(頭文件同名,別忘了加)。

代碼註釋

1.substr
字符串截斷,PAT常見操作

2.for(auto i:v)
如果用不到STL容器的編號就可以用這個c++14的枚舉特性

滿分代碼

#include<iostream>
#include<vector>
#include<unordered_map>
using namespace std;
int n,m,k,num=0,total=0;
string s;
struct node{
    string id;
    int value;
};
bool cmp(node &a,node &b){
    return a.value==b.value?a.id<b.id:a.value>b.value;
}
int main(){
    scanf("%d %d",&n,&m);
    vector<node> v(n);
    for(int i=0;i<n;i++){
        cin>>v[i].id>>v[i].value;
    }
    for(int i=1;i<=m;i++){
        cin>>k>>s;
        printf("Case %d: %d %s\n",i,k,s.c_str());
        vector<node> ans;
        if(k==1){
            for(auto it:v){
                if(it.id.substr(0,1)==s){
                    ans.push_back(it);
                }
            }
            if(ans.size()==0){
                printf("NA\n");
                continue;
            }
            sort(ans.begin(),ans.end(),cmp);
            for(auto j:ans){
                printf("%s %d\n",j.id.c_str(),j.value);
            }
        }else if(k==2){
            num=0;
            total=0;
            for(auto it:v){
                if(it.id.substr(1,3)==s){
                    num++;
                    total+=it.value;
                }
            }
            if(num==0){
                printf("NA\n");
                continue;
            }
            printf("%d %d\n",num,total);
        }else if(k==3){
            unordered_map<string, int> ans3;
            for(auto it:v){
                if(it.id.substr(4,6)==s){
                    ans3[it.id.substr(1,3)]++;
                }
            }
            if(ans3.size()==0){
                printf("NA\n");
                continue;
            }
            for(auto it:ans3){
                ans.push_back({it.first,it.second});
            }
            sort(ans.begin(),ans.end(),cmp);
            for(auto j:ans){
                printf("%s %d\n",j.id.c_str(),j.value);
            }
        }
    }
    return 0;
}

如果喜歡,請給我點贊或者評論,感謝

 

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章