HDU 1086 You can Solve a Geometry Problem too (判斷線段交叉,線段跨立)



You can Solve a Geometry Problem too
  Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u


Description

Many geometry(幾何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :) 
Give you N (1<=N<=100) segments(線段), please output the number of all intersections(交點). You should count repeatedly if M (M>2) segments intersect at the same point. 

Note: 
You can assume that two segments would not intersect at more than one point. 
 

Input

Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed. 
 

Output

For each case, print the number of intersections, and one line one case. 
 

Sample Input

2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
0.00 0.00 1.00 1.00
3
0.00 0.00 1.00 0.00
0.00 1.00 1.00 0.000
0
 

Sample Output

1
3
 

題目大意:

有 n 條直線,讓你判斷有多少個交點


分析:
判斷兩直線是否相交

分兩步:
①:快速排斥
   設以線段P1P2爲對角線的矩形爲R,以線段Q1Q2爲對角線的矩形爲T,如果R和T不相交,顯然兩線段不會相交。
②:跨立
   如果兩直線相交,則兩直線必然相互跨立對方。若P1P2跨立Q1Q2,則矢量(P1-Q1)和(P2-Q1)位於矢量(Q2-Q1)的兩側,
  即(P1-Q1)X(Q2-Q1)*(P2-Q1)X(Q2-Q1)<0. 上式可改寫爲(P1-Q1)X(Q2-Q1)*(Q2-Q1)X(P2-Q1)>0. 
當(P1-Q1)X(Q2-Q1)=0 時,說明(P1-Q1)和(Q2-Q1)共線,但因爲已經通過快速排斥實驗,所以
  P1一定在線段Q1Q2上,同理,(Q2-Q1)X(P2-Q1)=0 說明P2一定在直線Q1Q2上。所以判斷P1P2跨立Q1Q2的依據是:
(P1 - Q1) X (Q2 - Q1) * (Q2 - Q1) X (P2 -Q1)>=0        X 是叉乘的意思

附上一個判斷線段交叉的解題思路:http://blog.csdn.net/xia842655187/article/details/51469130 點擊打開鏈接


附上代碼:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <string>
#include <algorithm>
#include <vector>
#include <cmath>
#define LL long long
#define MAX_N 50000
using namespace std;

struct point
{
	double x,y;
};

struct Line
{
	point a,b;
};

int Seg(Line a,Line b)
{
    double k1=(a.a.x - b.a.x)*(b.b.y - b.b.x)-(a.b.x - b.b.x)*(b.a.y - b.a.x);
    double k2=(b.a.y - b.a.x)*(a.b.y - b.b.x)-(b.b.y - b.b.x)*(a.a.y - b.a.x);
    if(k1*k2>=0)
    	return 1;
    else
    	return 0;
}

int main()
{
	Line line[110];
	int n;
	while(cin >> n && n)
	{
		int ans = 0;
		for(int i = 0;i < n;i++)
		{
			scanf("%lf%lf%lf%lf",&line[i].a.x,&line[i].b.x,&line[i].a.y,&line[i].b.y);
			for(int j = 0;j < i;j++)
			{
				if(Seg(line[i],line[j]) && Seg(line[j],line[i]))
				ans++;
			}
		}
		cout << ans << endl;
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章