1076. Forwards on Weibo (30)【樹+搜索】——PAT (Advanced Level) Practise

題目信息

1076. Forwards on Weibo (30)

時間限制3000 ms
內存限制65536 kB
代碼長度限制16000 B

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

解題思路

合適的結構構造成樹再進行搜索

AC代碼

#include <cstdio>
#include <vector>
#include <queue>
using namespace std;
int n, level, tn, t, m;
vector<int> node[1005];

int find(int root){
    int s = 0;
    vector<bool> vis(n+1, false);
    queue<pair<int, int> > que;
    que.push(make_pair(root, 0));
    vis[root] = true;
    while (!que.empty()){
        int id = que.front().first;
        int lv = que.front().second;
        que.pop();
        if (lv >= level) continue;
        for (int i = 0; i < node[id].size(); ++i){
            if (!vis[node[id][i]]){
                vis[node[id][i]] = true;
                que.push(make_pair(node[id][i], lv + 1));
                ++s;
            }
        }
    }
    return s;
}
int main()
{
    scanf("%d%d", &n, &level);
    for (int i = 1; i <= n; ++i){
        scanf("%d", &tn);
        while (tn--) {
            scanf("%d", &t);
            if (t != i) node[t].push_back(i);
        }
    }
    scanf("%d", &m);
    while (m--){
        scanf("%d", &t);
        printf("%d\n", find(t));
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章