hdu 5086 Revenge of Segment Tree(BestCoder Round #16)

Revenge of Segment Tree

                                                         Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                                   Total Submission(s): 420    Accepted Submission(s): 180


Problem Description
In computer science, a segment tree is a tree data structure for storing intervals, or segments. It allows querying which of the stored segments contain a given point. It is, in principle, a static structure; that is, its content cannot be modified once the structure is built. A similar data structure is the interval tree.
A segment tree for a set I of n intervals uses O(n log n) storage and can be built in O(n log n) time. Segment trees support searching for all the intervals that contain a query point in O(log n + k), k being the number of retrieved intervals or segments.
---Wikipedia

Today, Segment Tree takes revenge on you. As Segment Tree can answer the sum query of a interval sequence easily, your task is calculating the sum of the sum of all continuous sub-sequences of a given number sequence.
 

Input
The first line contains a single integer T, indicating the number of test cases. 

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 10
2. 1 <= N <= 447 000
3. 0 <= Ai <= 1 000 000 000
 

Output
For each test case, output the answer mod 1 000 000 007.
 

Sample Input
2 1 2 3 1 2 3
 

Sample Output
2 20
Hint
For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20. Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded. And one more little helpful hint, be careful about the overflow of int.
 

求一段序列的所有連續子序列的和。
對於序列中的第i個,下標從0開始,在第ai個前有i+1個數(包括它自己),在ai個後有n-i個(包括它自己),所以ai
共出現(i+1)*(n-i)次。
 
*心累唉,考慮到是這樣的思路,但是沒能找出規律,每次的規律題都做不出來T-T    文章轉載自http://blog.csdn.net/caduca/article/details/40706465

官方題解:
考慮每個數出現在多少個子序列之中,假設第i個數爲Ai,區間爲[L,R]。那麼包含Ai的區間滿足LiRi。累加(L+1)(NR)A[i]就可以了。
代碼:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
long long mod=1000000000+7;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long n;
        long long ans=0;
        long long a;
        scanf("%I64d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%I64d",&a);
            ans=(ans+(((a*(i+1)%mod)*(n-i))%mod))%mod;
        }
        printf("%I64d\n",ans);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章