1019:Least Common Multiple

Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

 

 

Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
 

 

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
 

 

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1
 

 

Sample Output
105 10296
代碼:
#include <stdio.h>
#include<cstring>

int GetGCDRec(int n,int m)
{
 if(n%m==0)
  return m;
 return GetGCDRec(m,n%m);
}
int main()
{
 int n,m;
 int temp;
 int a;
 scanf("%d",&n);
 while(n--)
 {
  scanf("%d",&m);
  scanf("%d",&temp);
  while(--m)
  {
   scanf("%lld",&a);
   if(a>temp)
    temp=a/GetGCDRec(a,temp)*temp;
   else
    temp=a/GetGCDRec(temp,a)*temp;    
  }
  printf("%d/n",temp);
 }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章