1016:Prime Ring Problem

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

 

Sample Input
6 8
 

 

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

 

代碼:(雖然不知道爲什麼提交通過不了···還是貼上來了···希望明眼人明示···)

#include <stdio.h>
#include<cstring>

int primelist[38] = {0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1}; 
int a[10000];
int visited[30];

int isPrime(int n)
{
 if(primelist[n])
  return 1;
 return 0;
}

void primeCircle(int cur,int n)

 if(cur==n&&isPrime(1+a[n-1]))
 {
  for(int i=0;i<n-1;i++)
   printf("%d ",a[i]);
  printf("%d/n",a[n-1]);
 }
 else
 { 
  for(int i=2;i<=n;i++)
   if(isPrime(a[cur-1]+i)&&visited[i]==0)
   {
    a[cur]=i;
    visited[i]=1;
    primeCircle(cur+1,n);
    visited[i]=0;
   }
 }
}

int main()
{

 int n,num=1;
 a[0]=1;
 memset(visited,0,sizeof(visited));
 visited[1]=1;

 while(scanf("%d",&n)==1)
 {
  printf("case %d:/n",num++);
  primeCircle(1,n);
  printf("/n");
 }

    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章