PAT甲級真題 1079 Total Sales of Supply Chain (25分) C++實現(帶深度的DFS)

題目

A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4

思路

把銷售渠道視爲樹,用鄰接表e存儲節點連接關係;零售商相當於葉子節點,用額外的數組num存儲其貨物量。

貨物從根出發,每經過一層價格都會提高r%,經過n層的價格就是(1+r%) n

用dfs找出每個葉子節點的深度,進而求出它的價格,再乘以其貨物量即可得到總銷售額。由於圖中無環,所以無需使用visited數組,dfs可以很簡化。

小技巧:可先把原始售價視爲1,到最後一步再乘以p。

代碼

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;

vector<vector<int> > e;
vector<int> num;
double n, p, r;
double sum = 0.0;

void dfs(int root, int layer){
    if (e[root].size()==0){
        sum += (num[root] * pow(r, layer));
        return;
    }
    for (int i=0; i<e[root].size(); i++){
        dfs(e[root][i], layer+1);
    }
}
int main(){
    cin >> n >> p >> r;
    e.resize(n);
    num.resize(n);
    r = (1 + r/100);
    for (int i=0; i<n; i++){
        int k;
        cin >> k;
        if (k==0){
            cin >> num[i];
        }
        while (k--){
            int temp;
            cin >> temp;
            e[i].push_back(temp);
        }
    }
    dfs(0, 0);
    printf("%.1lf\n", sum * p);
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章