【題解】 HDU 3572 SPY

目錄

 

題目描述

題意分析

AC代碼


題目描述

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The National Intelligence Council of X Nation receives a piece of credible information that Nation Y will send spies to steal Nation X’s confidential paper. So the commander of The National Intelligence Council take measures immediately, he will investigate people who will come into NationX. At the same time, there are two List in the Commander’s hand, one is full of spies that Nation Y will send to Nation X, and the other one is full of spies that Nation X has sent to Nation Y before. There may be some overlaps of the two list. Because the spy may act two roles at the same time, which means that he may be the one that is sent from Nation X to Nation Y, we just call this type a “dual-spy”. So Nation Y may send “dual_spy” back to Nation X, and it is obvious now that it is good for Nation X, because “dual_spy” may bring back NationY’s confidential paper without worrying to be detention by NationY’s frontier So the commander decides to seize those that are sent by NationY, and let the ordinary people and the “dual_spy” in at the same time .So can you decide a list that should be caught by the Commander?
A:the list contains that will come to the NationX’s frontier.
B:the list contains spies that will be sent by Nation Y.
C:the list contains spies that were sent to NationY before.

Input

There are several test cases.
Each test case contains four parts, the first part contains 3 positive integers A, B, C, and A is the number which will come into the frontier. B is the number that will be sent by Nation Y, and C is the number that NationX has sent to NationY before. 
The second part contains A strings, the name list of that will come into the frontier.
The second part contains B strings, the name list of that are sent by NationY.
The second part contains C strings, the name list of the “dual_spy”.
There will be a blank line after each test case.
There won’t be any repetitive names in a single list, if repetitive names appear in two lists, they mean the same people.

Output

Output the list that the commander should caught (in the appearance order of the lists B).if no one should be caught, then , you should output “No enemy spy”

Sample Input

8 4 3

Zhao Qian Sun Li Zhou Wu Zheng Wang

Zhao Qian Sun Li

Zhao Zhou Zheng

2 2 2

Zhao Qian

Zhao Qian

Zhao Qian

Sample Output

Qian Sun Li

No enemy spy

 

題意分析

題意:某國潛入間諜,現在給你三份表單,間諜就在 1 和 2 的交集   沒有在3中出現的。

            一開始的思路是使用關聯容器MAP,通過操縱鍵值來達到目的,然而它需要按照表序輸出

            MAP會對關鍵字進行排序,就WA了,也可以通過重載運算符來達到目的,但在下才疏學淺,

            歡迎大佬在評論下方實現。

            同時注意find函數在<algorithm> 而不是<string>中的

            返回第一個與所查詢值相同的迭代器,如果沒找到則返回end迭代器

 

最下方有AC代碼

 

錯誤代碼

#include <iostream>
#include <map>
#include <string>
using namespace std;

map <string ,int> s;
map <string ,int> :: iterator it;

int main()                             //  此份代碼不能AC ,提供思路耳
{
    int n,m,k,sign,mark,i,p;
    string r;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        s.clear();
        sign=0;mark=0;p=0;
        for(i=0;i<n;i++)
        {
            cin>>r;
            s[r]++;
        }
        for(i=0;i<m;i++)
        {
            cin>>r;
            s[r]=-1;
        }
        for(i=0;i<k;i++)
        {
            cin>>r;
            s[r]=1;
        }
        for(it=s.begin(); it!=s.end();it++)
        {
            if( it->second == -1)
            {
                if(sign==1) cout<<' ';
                cout<< it->first ;
                sign=1;
                mark=1;
            }
        }
        if(mark==0) cout<<"No enemy spy"<<endl;
        else cout<<endl;
    }
    return 0;
}

 

 

 

 

AC代碼

#include <iostream>
#include <string>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;

vector <string> x,y,z,s;
int main()
{
    int n,m,k,i;
    string r;
    while(~scanf("%d%d%d",&n,&m,&k))
    {
        x.clear();y.clear();z.clear();s.clear();
        for(i=0;i<n;i++)
        {
            cin>>r;
            x.push_back(r);
        }
        for(i=0;i<m;i++)
        {
            cin>>r;
            y.push_back(r);
        }
        for(i=0;i<k;i++)
        {
            cin>>r;
            z.push_back(r);
        }

        for(i=0;i<m;i++)
        {
            if(find(x.begin(),x.end(),y[i])!=x.end())     // 注意
            if(find(z.begin(),z.end(),y[i])==z.end())

            s.push_back(y[i]);
        }
        if(s.size()==0)
        {
            cout<<"No enemy spy"<<endl;
        }
        else
        {
            for(i=0;i<s.size();i++)
            {
                cout<<s[i];
                if(i!=s.size()-1)
                {
                    cout<<' ';
                }
                else
                {
                    cout<<endl;
                }
            }
        }
    }
    return 0;
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章