Girls and Boys||HDU1068

link:http://acm.hdu.edu.cn/showproblem.php?pid=1068
Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

題解:二分的最大獨立集
最大獨立集:
在二分圖中,獨立集指的是兩兩之間沒有邊的頂點的集合,頂點最多的獨立集成爲最大獨立集。
二分圖的最大獨立集=節點數-最大匹配數
利用匈牙利算法就行,不過傳統的模板要做一些改變,因爲這個裏面沒有男生數和女孩數,只有數字喜歡數字,那我們就算出相愛的數字數然後除以2,就是最大匹配數(因爲每個樣例裏給出的數字都是互相喜歡的),然後n減去這個數就是結果
AC代碼:

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;
int f[1010];
bool fr[1010][1010];
bool vis[1010];
int n;
int find(int x)
{
    int i;
    for ( i=0 ; i<n ; i++ )
    {
        if ( fr[x][i] && !vis[i] )
        {
            vis[i] = true;
            if ( f[i]==-1 || find(f[i]) )
            {
                f[i] = x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    int i,a,b,c,d,ans;
    while(~scanf("%d",&n))
    {
        memset(f,-1,sizeof(f));
        memset(fr,false,sizeof(fr));
        ans=0;
        for ( i=0 ; i<n ; i++ )
        {
            scanf("%d: (%d)",&a,&b);
            while(b--)
            {
                scanf("%d",&c);
                fr[a][c] = true;//互相喜歡 
                fr[c][a] = true;
            }
        }
        for ( i=0 ; i<n ; i++ )
        {
            memset(vis,false,sizeof(vis));
            if ( find(i) )
                ans++;
        }
        ans /= 2;
        printf("%d\n",n-ans);
    }
return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章