Poj 2096 Collecting Bugs (概率DP求期望)

C - Collecting Bugs
Time Limit:10000MS     Memory Limit:64000KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

題目大意

 

一個軟件有 s 個子系統,存在 n 種 bug。某人一天能找到一個 bug。問,在這個軟件中找齊 n 種 bug,

並且每個子系統中至少包含一個 bug 的時間的期望值(單位:天)。注意:bug 是無限多的,每個 bug

屬於任何一種 bug 的概率都是 1/n;出現在每個系統是等可能的,爲 1/s。

 

做法分析

 

令 f[i][j] 表示已經找到了 i 種 bug,且 j 個子系統至少包含一個 bug,距離完成目標需要的時間的期望。

目標狀態是 f[0][0]


再過一天找到一個 bug 可能是如下的情況:

        1. 這個 bug 的種類是 已經找到的 並且 出現在 已經找到 bug 的子系統中

        2. 這個 bug 的種類是 已經找到的 並且 出現在 沒有找到 bug 的子系統中

        3. 這個 bug 的種類是 沒有找到的 並且 出現在 已經找到 bug 的子系統中

        4. 這個 bug 的種類是 沒有找到的 並且 出現在 沒有找到 bug 的子系統中

 

經過簡單的分析,不難得出如下遞推過程:

        f[i][j] =    i/n*j/s*f[i][j]

                     + i/n*(s-j)/s*f[i][j+1]

                     + (n-i)/n*j/s*f[i+1][j]

                     + (n-i)/n*(s-j)/s*f[i+1][j+1]

 

移項可得

         (1-(i*j)/(n*s))f[i][j] =    i/n*(s-j)/s*f[i][j+1]

                                          + (n-i)/n*j/s*f[i+1][j]

                                          + (n-i)/n*(s-j)/s*f[i+1][j+1]

逆向遞推即可

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
double f[1005][1005];
int main()
{
    int n,s;
    while(scanf("%d%d",&n,&s)!=EOF)
    {
        memset(f,0,sizeof(f));
        for(int i=n;i>=0;i--)
        {
            for(int j=s;j>=0;j--)
            {
                if(i==n&&j==s)
                    continue;
                double p1=double(s-j)*i/n/s;
                double p2=double(n-i)*j/n/s;
                double p3=double(n-i)*(s-j)/n/s;
                double p0=1.0-double(i*j)/n/s;
                f[i][j]=p1*f[i][j+1]+p2*f[i+1][j]+p3*f[i+1][j+1]+1;
                f[i][j]/=p0;
            }
        }
        printf("%.4f\n",f[0][0]);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章