HDU 6318(樹狀數組)

Swaps and Inversions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 449    Accepted Submission(s): 166


 

Problem Description

Long long ago, there was an integer sequence a.
Tonyfang think this sequence is messy, so he will count the number of inversions in this sequence. Because he is angry, you will have to pay x yuan for every inversion in the sequence.
You don't want to pay too much, so you can try to play some tricks before he sees this sequence. You can pay y yuan to swap any two adjacent elements.
What is the minimum amount of money you need to spend?
The definition of inversion in this problem is pair (i,j) which 1≤i<j≤n and ai>aj.

 

 

Input

There are multiple test cases, please read till the end of input file.
For each test, in the first line, three integers, n,x,y, n represents the length of the sequence.
In the second line, n integers separated by spaces, representing the orginal sequence a.
1≤n,x,y≤100000, numbers in the sequence are in [−109,109]. There're 10 test cases.

 

 

Output

For every test case, a single integer representing minimum money to pay.

 

 

Sample Input


 

3 233 666 1 2 3 3 1 666 3 2 1

 

 

Sample Output


 

0 3

 

每次交換最多減少一個逆序對。

假設逆序對有num個,那麼答案就是min(num*x,num*y)

離散化+樹狀數組即可

#include<bits/stdc++.h>
#define mp make_pair
#define fir first
#define se second
#define ll long long
#define pb push_back
using namespace std;
const int maxn=5e5+10;
const ll mod=1e9+7;
const int maxm=1e6+10;
const double eps=1e-7;
const ll inf=(ll)1e13;
int n;
ll tree[maxn];
int a[maxn];
int lowbit(int x){
    return x&(-x);
}
void update(int x,int d){
    for (int i=x;i<=n;i+=lowbit(i)){
        tree[i]+=d;
    }
}
ll getsum(int x){
    ll ans=0;
    for (int i=x;i>0;i-=lowbit(i))
        ans+=tree[i];
    return ans;
}
map<int,int> ma;
int b[maxn];
ll x,y;
int main(){
    while(scanf("%d %lld %lld",&n,&x,&y)!=EOF){
        for (int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            b[i]=a[i];
        }
        sort(b+1,b+n+1);
        int cnt=1;
        ma.clear();
        for (int i=1;i<=n;i++)
            ma[b[i]]=cnt++;
        for (int i=1;i<=n;i++)
            a[i]=ma[a[i]];
        for (int i=0;i<=n;i++) tree[i]=0;
        ll ans=0;
        for (int i=n;i>=1;i--){
            ans+=getsum(a[i]-1);
            update(a[i],1);
        }
        printf("%lld\n",ans*min(x,y));
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章