C++_FatMouse' Trade(貪心)

Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

思路

獲得每一個的價格,然後每次都拿最小的。一開始建立了三個數組,然後打算自己寫一個排序算法,根據價格的值同時修改三個數組,後來受人指點,把三個值寫成一個結構體就行了。

#include <iostream>
#include <cstdio>
#include <vector>
#include <algorithm>
#define N 1005

//#define DEBUG
using namespace std;

int m, n;
double ans;
struct Fat{
    double price;
    int j, f;
};

vector<Fat> good(N);

bool myCompare(Fat a, Fat b) { return a.price < b.price; }

int main()
{
    while(~scanf("%d%d", &m, &n))
    {
        ans = 0;
        if(m<0||n<0) break;
        for(int i = 0;i<n;i++)
        {
            scanf("%d%d", &good[i].j, &good[i].f);
            good[i].price = (double)good[i].f/(double)good[i].j;
        }
        sort(good.begin(), good.begin() + n, myCompare);
#ifdef DEBUG
        for(int i= 0;i<n;i++)
        {
            cout << " J : " << good[i].j << "F : " << good[i].f
             << endl << "Price : " << good[i].price << endl;
        }
#endif // DEBUG
        for(int i = 0;i<n;i++)
        {
            if(m<=0) break;
            if(m>=good[i].f)
            {
                ans+=good[i].j;
                m-=good[i].f;
            }
            else
            {
                ans+=(double)m/good[i].price;
                m = 0;
            }
        }
        printf("%.3lf\n", ans);


    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章