POJ 2002 Square

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

題意:平面上給定n個點,求由這些點能構成多少個正方形。

考察點:計算幾何,二維點哈希

分析:我們枚舉兩個點,那麼在這兩個點形成的直線兩邊可以計算出正方形的另外兩個點,利用Hash然後查找即可。由於一個正方形的邊都會被遍歷,所以最終答案需要除以4.

#include <iostream>
#include <string.h>
#include <stdio.h>

using namespace std;
typedef long long LL;
const int N = 1005;
const int H = 10007;

struct Point
{
    int x,y;
};

Point p[N];

struct Node
{
    int x,y;
    int next;
};

Node node[N];
int cur,n;
LL ans;

int Hash[H];

void Init()
{
    for(int i=0;i<H;i++)
       Hash[i] = -1;
    cur = ans = 0;
}

void Insert(int x,int y)
{
    int h = (x * x + y * y) % H;
    node[cur].x = x;
    node[cur].y = y;
    node[cur].next = Hash[h];
    Hash[h] = cur++;
}

bool Search(int x,int y)
{
    int h = (x * x + y * y) % H;
    int t = Hash[h];
    while(t != -1)
    {
        if(x == node[t].x && y == node[t].y) return true;
        t = node[t].next;
    }
    return false;
}

LL Work()
{
    Init();
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&p[i].x,&p[i].y);
        Insert(p[i].x,p[i].y);
    }
    for(int i=0;i<n;i++)
    {
        for(int j=i+1;j<n;j++)
        {
            int x1 = p[i].x - (p[i].y - p[j].y);
            int y1 = p[i].y + (p[i].x - p[j].x);
            int x2 = p[j].x - (p[i].y - p[j].y);
            int y2 = p[j].y + (p[i].x - p[j].x);
            if(Search(x1,y1) && Search(x2,y2)) ans++;
        }
    }
    for(int i=0;i<n;i++)
    {
        for(int j=i+1;j<n;j++)
        {
            int x1 = p[i].x + (p[i].y - p[j].y);
            int y1 = p[i].y - (p[i].x - p[j].x);
            int x2 = p[j].x + (p[i].y - p[j].y);
            int y2 = p[j].y - (p[i].x - p[j].x);
            if(Search(x1,y1) && Search(x2,y2)) ans++;
        }
    }
    ans >>= 2;
    return ans;
}

int main()
{
    while(~scanf("%d",&n),n)
        printf("%I64d\n",Work());
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章